Outlook doesn't load any addin-module anymore

Add-in Express™ Support Service
That's what is more important than anything else

Outlook doesn't load any addin-module anymore
problem with Outlook add in module 
Bob Milani




Posts: 13
Joined: 2005-01-28
I upgraded my addin express to 2.2, and for few days everything was fine. Then suddenly, without changing anything, the application stoppped working. (I'm using Outlook 2003).

The problem was in the debug mode, outlook would terminate right after running the application. In the normal mode, the plugin wouldn't load. Trying to load the plugin from the Options/Other/COM Add-ins would terminate the outlook.

I removed Add-in Express and reinstalled it. Now Outlook doesn't terminate anymore, but it also can't load the plugin. I can see the name of the plugin in the COM Add-ins dialog, but it's not checked. Checking it doesn't make any change. It doesn't even show "There was a problem during the load of this module" message.

I tried the "MyFirstOutlookAddin" sample, and I have exactly the same problem with that sample as well.

I removed all the registry entries for this plugin (and MyFirstOutlookAddin), but it dodn't solve my problem.

Could you please help me?

Thanks.
Posted 22 Jul, 2005 17:16:31 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Bob.

Do you have both VS2003 and VS2005 installed on your PC?
Posted 25 Jul, 2005 05:59:17 Top
Bob Milani




Posts: 13
Joined: 2005-01-28
Hi Sergey,

Yes, I have both versions installed on my machine, but again, after installing VS.2005 I didn't have any problem for about 1 week, or two. Also, after having this problem, I re-installed VS.2003.

I understand if you're ot supporting VS.2005, but it would be very inconvinient if you tell me that I can't even have VS.2005 on my machine.

Thanks
Posted 25 Jul, 2005 12:42:15 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Bob.

Unfortunately Add-in Express doesn't work correctly when both VS 2003 and VS 2005 Beta 2 are on the same machine.

I think the cause of the problem is in the mscoree.dll. This dll is updated by the VS 2005 installation program.

We are going to support VS 2005 soon. I think we will publish a new ADX build for VS2005 at the beginning of the September.
Sorry for inconvenience.

Posted 26 Jul, 2005 02:29:46 Top
Bob Milani




Posts: 13
Joined: 2005-01-28
Hi Sergey,

This is REALLY a bad news. I'm in the middle of developing another application with VS.2005, and what you're telling me is I either have to stop working on this project or the other project.

Can you have a quick fix just to address this problem? 1.5 months is a lot of time...
Posted 26 Jul, 2005 12:47:09 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Bob.

What about two weeks?
Posted 26 Jul, 2005 13:03:18 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Bob, what language do you use to develop the add-in? I could support VS2005 for one language first and send you a build.
Posted 26 Jul, 2005 13:10:06 Top
Bob Milani




Posts: 13
Joined: 2005-01-28
I'm using C#. But the problem is I'm working on two different application. The old one (which is in C# as well) is using VS2003, and for the new one I'm using VS2005. There's no way for me to remove VS2005, and I can't compile the old application with VS2005.

I really hope you can help me with that. I'd be in a big problem if I can't get the old application work on my machine.

Thanks
Posted 26 Jul, 2005 18:10:03 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Bob.

Ok. I will try to help asap.
Posted 27 Jul, 2005 06:04:27 Top
Bob Milani




Posts: 13
Joined: 2005-01-28
thanks Sergey for your effort. I'll be waiting to hear from you.

--Bob
Posted 28 Jul, 2005 14:30:57 Top