Cannot register assembly..

Add-in Express™ Support Service
That's what is more important than anything else

Cannot register assembly..
Unable to create specified ActiveX control... 
Vamshi Kothur




Posts: 6
Joined: 2009-03-01
Hi,

I am getting the following exception after restarting Vista after disabling UAC.

"Error 6 Cannot register assembly "C:\Users\vkothur\Documents\WORD ADD In\DOC Samples\VS 2005\C#\Your First Microsoft Office Add-in\MyAddin1\bin\Debug\MyAddin1.dll" - access denied. Please make sure you're running the application as administrator. Access to the registry key 'HKEY_CLASSES_ROOT\MyAddin1.StepThrough' is denied. MyAddin1
"

I have a taskpane with a usercontrol on it. It worked fine all the while and all of a sudden I get this error when I build. I tried everything suggested in this forum like run VS 2008 as Administrator etcetc. I commented out all reference to ADXTaskPane and now it builds successfully but when any change is done the above error reappears.

And I get below error when I open Word.
"Detailed technical information follows:
---
Date and Time: 4/14/2009 11:59:18 PM
Machine Name: NCUS-VKOTHURIT
IP Address: fe80::143c:37b9:3f57:fe9b%29
Current User: ncus-vkothurit\vkothur

Application Domain: C:\Users\vkothur\Documents\WORD ADD In\DOC Samples\VS 2005\C#\Your First Microsoft Office Add-in\MyAddin1\bin\Debug\
Assembly Codebase: file:///C:/Windows/assembly/GAC_MSIL/AddinExpress.MSO.2005/4.4.1913.2005__4416dd98f0861965/AddinExpress.MSO.2005.dll
Assembly Full Name: AddinExpress.MSO.2005, Version=4.4.1913.2005, Culture=neutral, PublicKeyToken=4416dd98f0861965
Assembly Version: 4.4.1913.2005
Assembly Build Date: 3/28/2005 2:06:50 AM

Exception Source:
Exception Type: System.Runtime.InteropServices.COMException
Exception Message: Unable to create specified ActiveX control.
Exception Target Site: ForwardCallToInvokeMember

---- Stack Trace ----
System.RuntimeType.ForwardCallToInvokeMember(memberName As String, flags As BindingFlags, target As Object, aWrapperTypes As Int32[], msgData As MessageData&)
AddinExpress.MSO.2005.dll: N 0197 (0xC5) IL
AddinExpress.MSO.ICTPFactory.CreateCTP(CTPAxID As String, CTPTitle As String, CTPParentWindow As Object)
AddinExpress.MSO.2005.dll: N 00000 (0x0) JIT
AddinExpress.MSO.ADXAddinModule.AddCustomTaskPanes(parent As Object, outlookFolderName As String)
AddinExpress.MSO.2005.dll: N 0000 (0x0) IL

________________________________________________________________
This is the same Addin project downloaded from your site with Taskpane. The sln is called MyAddin1.sln.

Please help. This is frustrating me.
Thanks!
Posted 15 Apr, 2009 01:08:27 Top
Andrei Smolin


Add-in Express team


Posts: 15492
Joined: 2006-05-11
Hello Vamshi,

You need to turn the UAC on and run VS as administrator.

Regards from Belarus (GMT+2),

Andrei Smolin
Add-in Express Team Leader
Posted 15 Apr, 2009 07:09:39 Top