Error when loading VSTO add-in

Add-in Express™ Support Service
That's what is more important than anything else

Error when loading VSTO add-in
 
Daniel Rail




Posts: 14
Joined: 2008-10-03
Hi,

I developed an Outlook add-in using "Add-in Express 2008 for VSTO", .Net 3.5 SP1 and VS 2008 SP1. When testing the deployment, the first computers we installed it on worked fine. But, we encountered some problems on other computers. The installation itself goes well, but the add-in doesn't want to load in Outlook. After some research, we found out that another add-in on that computer is using .Net 1.1, and most likely that is our conflict, because .Net 1.1 is the framework that gets loaded. And we can't disable that add-in, because the user is using it.

Since it seems almost impossible to work around this scenario and still be using VSTO, would "Add-in Express 2008 for Office and .Net" be a solution to this problem?

Or are there other solutions(other than having to create my own COM add-in shim and having to possibly rewrite the add-in)?

Posted 12 Feb, 2009 11:20:51 Top
Andrei Smolin


Add-in Express team


Posts: 14108
Joined: 2006-05-11
Hi Daniel,

and most likely that is our conflict


You can check if this is the case; just turn that add-in off.

Or are there other solutions


You can try creating a config file specifying the .NET Framework version to be loaded is 2.0 and check if this allows that other add-in to run. Or, I can create such a file for you: please send me a message to the support e-mail address (see readme.txt). Please specify the host application.

Since it seems almost impossible to work around this scenario and still be using VSTO, would "Add-in Express 2008 for Office and .Net" be a solution to this problem?


If only this is a conflict and if the config file doesn't help to solve it, then there's no way to solve it on the .NET platform because 1.1 and 2.0 (and higher) aren't 100% compatible. Any shim will not help in this case.

Good luck to you as you defenitely need a good portion of luck.

Regards from Belarus (GMT+2),

Andrei Smolin
Add-in Express Team Leader
Posted 12 Feb, 2009 13:10:57 Top
Daniel Rail




Posts: 14
Joined: 2008-10-03
Hi,

I did turn that add-in off, and even all the other add-ins, just to see what happens. But, there still seemed to have something loading .Net 1.1. Here's the log entry that FUSLOGVW.exe picked up:


*** Assembly Binder Log Entry  (2/11/2009 @ 10:43:17 AM) ***
 
The operation was successful.
Bind result: hr = 0x0. The operation completed successfully.
 
Assembly manager loaded from:  c:WINDOWSMicrosoft.NETFramework1.1.4322usion.dll
Running under executable  C:Program FilesMicrosoft OfficeOffice12OUTLOOK.EXE
--- A detailed error log follows. 
 
=== Pre-bind state information ===
LOG: DisplayName = mscorlib, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
 (Fully-specified)
LOG: Appbase = c:WINDOWSMicrosoft.NETFramework1.1.4322
LOG: Initial PrivatePath = NULL
LOG: Dynamic Base = NULL
LOG: Cache Base = NULL
LOG: AppName = NULL
Calling assembly : (Unknown).
===
 
LOG: Not processing DEVPATH because this is a pre-jit assembly bind.
LOG: Policy not being applied to reference at this time (private, custom, partial, or location-based assembly bind).
LOG: Post-policy reference: mscorlib, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
LOG: Found assembly by looking in the cache.


So I think I will need to create a config file. Where can I find such information? Because, I'm only finding some its and pieces of information, but not a complete reference(i.e. where that file should be located and what can go in it).
Posted 13 Feb, 2009 09:29:11 Top
Andrei Smolin


Add-in Express team


Posts: 14108
Joined: 2006-05-11
Daniel,

Please download it at http://www.add-in-express.com/files/excel.exe.config.

The file must be located in Program Files\Microsoft Office\Office1x.

I'd also disable smart tags.

Regards from Belarus (GMT+2),

Andrei Smolin
Add-in Express Team Leader
Posted 13 Feb, 2009 11:00:46 Top
Daniel Rail




Posts: 14
Joined: 2008-10-03
Thanks,

That worked. :)
Posted 13 Feb, 2009 16:22:22 Top