Manifest authoring error c1010005

Add-in Express™ Support Service
That's what is more important than anything else

Manifest authoring error c1010005
Andrew Szczeszynski

Posts: 44
Joined: 2007-02-02
Hi there,

I just started using the tool, so please pardon me for asking silly questions.

I installed the tool out-of-the-box and tried repeating one of the videos. I'm using Microsoft Visual Studio 2005 (Version 8.0.50727), installed with C++ support. I created a new C++ plug-in for Word, and tried compiling after the new project wizard finished with all the initialization. I get the following error:

Embedding manifest...
.\Loader\adxloader.dll.manifest : manifest authoring error c1010005: The root element name should be <assembly/>.

The manifest file is as follows:

<?xml version="1.0" encoding="utf-8"?>
<assemblyIdentity name="WordNLI, PublicKeyToken=72253fdfa5636b4e" />
<loaderSettings generateLogFile="true" shadowCopyEnabled="true" privileges="user" />

I could not figure out how to make it work.

Note: I originally did not have .NET framework 2.0 (I had only 3.0 installed) - I have installed that, uninstalled and re-installed ADX .NET, but it does not fix the problem. Also, note that Visual Basic plug-ins do work, they succeed in building the manifest, only the C++ plug-ins fail.

Also, note that when the project is first created, it successfully embeds the manifest (log:

------ Build started: Project: MyAddin2, Configuration: Debug Win32 ------
Copying 'c:\programming\NLI\MyAddin2\MyAddin2\OfficePIAs\Interop.Word.dll' to target directory...
Copying 'c:\programming\NLI\MyAddin2\MyAddin2\OfficePIAs\Interop.VBIDE.dll' to target directory...
Copying 'c:\programming\NLI\MyAddin2\MyAddin2\OfficePIAs\Interop.Office.dll' to target directory...
Generating Code...
Performing unregistration
Unregistering previous project output for COM Interop...
Compiling manifest to resources...
Embedding manifest...
Build Time 0:03
Build log was saved at "file://c:\programming\NLI\MyAddin2\MyAddin2\Debug\BuildLog.htm"
MyAddin2 - 0 error(s), 0 warning(s)
========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========

It's only when I rebuild that it fails.

Anyone know what I am missing, or a work-around? (I'm using Office 2003)


Posted 02 Feb, 2007 17:01:52 Top
Sergey Grischenko

Add-in Express team

Posts: 7233
Joined: 2004-07-05
Hi Andrew.

Thank you for the bug report. You just need to exclude the adxloader.dll.manifest from build. Please open the Property Page dialog of the adxloader.dll.manifest file in Visual Studio and set the 'Exclude From Build' property to 'Yes'.

P.S. Note that we take up your forum requests in the order we receive them.
Besides, it may take us some time to investigate your issue. Please be sure we will let you know as soon as the best possible solution is found.
Posted 04 Feb, 2007 20:52:35 Top