AddIn stops working when Outlook started with no UI

Add-in Express™ Support Service
That's what is more important than anything else

AddIn stops working when Outlook started with no UI
 
Dave Gardner


Guest


Hi,

When an external application automates Outlook by starting it without a UI, and then Outlook is subsequently opened by the user we are finding some problems with our add-in.

The behaviour I am seeing is our AddIn is initialised when Outlook is first started without a UI. I can see this because of some logs that are generated. However after the user opens Outlook (whilst Outlook is still running without a UI) the AddIn no longer works.

Also when the user subsequently closes Outlook the outlook.exe process continues to stay running in the background - the main UI has disappeared, but the icon is still showing in the notification tray. This is after the program that started Outlook without a UI in the first place has exited also.

I can provide a sample project and a sample VBScript that starts Outlook without a UI if that is of any help diagnosing this issue.

We are using the latest version of Add-In Express for .NET and ADX extensions for Outlook, and are running under .NET 2.0. The client machines are running both Windows 2000 SP4 and Windows XP SP2 and Office 2003 SP2.

Thanks,
Dave Gardner
Posted 01 Feb, 2007 07:49:29 Top
Fedor Shihantsov


Guest


Thanks Dave,

We will look into this and let you know ASAP.

P.S. Note that we take up your forum requests in the order we receive them.
Besides, it may take us some time to investigate your issue. Please be sure we will let you know as soon as the best possible solution is found.
Posted 01 Feb, 2007 08:12:02 Top
Dave Gardner


Guest


Hi Fedor,

Have you been able to replicate this issue yet? I can provide a sample project and VBScript that automates Outlook without a UI if that is of any help.

Regards,
Dave
Posted 06 Feb, 2007 00:31:51 Top
Fedor Shihantsov


Guest


Hi Dave,

I have reprodused this issue. We will fix this issue in one of releases but, sorry, we will not be able to include this fix in the nearest release.
Posted 06 Feb, 2007 10:39:52 Top
Dave Gardner


Guest


Hi Fedor,

Thanks for the feedback.

Can you please tell me how long till the fix for this is likely to be available?

Regards,
Dave
Posted 07 Feb, 2007 00:13:44 Top
Fedor Shihantsov


Guest


Dave,

I think we will know this on the next week.
Posted 07 Feb, 2007 06:28:21 Top
Nick Randolph




Posts: 14
Joined: 2007-02-13
Fedor

I was just wondering if you had any update on this fix - the reason we ask is that it a show-stopper for our application. For our clients to adopt our software it cannot conflict with any existing software that integrates with Outlook. A resolution to this issue would help our adoption considerably.

Many thanks

Nick
Posted 13 Feb, 2007 22:07:44 Top
Andrei Smolin


Add-in Express team


Posts: 18782
Joined: 2006-05-11
Nick,

The date for Release 4 is not set yet. However, it cannot be published earlier than March, 15.
Posted 14 Feb, 2007 05:51:48 Top
Nick Randolph




Posts: 14
Joined: 2007-02-13
Smolin

Thank you for your response on this matter. As a premium level customer we were expecting a quicker response on this matter. Further to my previous post this issue is a significant issue and would warrant us looking at alternative products that do not have this same issue.

Please advise if there is a workaround for this issue while we await your next release.

Thanks

Nick
Posted 14 Feb, 2007 18:31:44 Top
Andrei Smolin


Add-in Express team


Posts: 18782
Joined: 2006-05-11
Nick,

We are considering creating a Premium Build that will fix this bug. Tomorrow, I will have more info on this.

Andrei Smolin
Add-in Express Team Leader
Posted 15 Feb, 2007 08:06:38 Top