Target Framework version

Add-in Express™ Support Service
That's what is more important than anything else

Target Framework version
 
Gilles Vollant




Posts: 4
Joined: 2015-10-10
Hello,
My VS.net projet has "Target Framework version" : ".NET Framework 4.5".

I've some user with .Net 4.5 (or 4.6). Most most uses 4.7x of course.

If I don't uses new API in my code, what improvement I can expect by setting Target to 4.7 ?

By example, somes feature for high dpi ...

Do you think I must upgrade the target framework and ask user to upgrade .net ?
Posted 08 Oct, 2018 04:39:23 Top
Andrei Smolin


Add-in Express team


Posts: 16197
Joined: 2006-05-11
Hello Gilles,

I don't think that I'm in a position to suggest anything as this is you who decides if the improvements that 4.7 provides are required by your add-in. As to the DPI-related things, the improvement that we wait from Microsoft is: standard controls (from COMCTL32) should support changing DPI dynamically. As this isn't done, there's no difference between 4.0 and 4.7.2.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 08 Oct, 2018 06:39:21 Top