Problem with Add In Registration

Add-in Express™ Support Service
That's what is more important than anything else

Problem with Add In Registration
Brendon Colloty



I have an Outlook Add in developed in Version 2.7 and using the ADX Loader.

It installs fine on nearly every client machine but on the odd one I get the following ADX Loader Error during installation

"The 'DLLRegister' function failed during execution (HRESULT = -2146232828)"

I get this error message twice and then the setup backs out and the installation failes.

Any ideas?

Tbanks in advance,

Brendon Colloty
Posted 27 Aug, 2006 20:56:57 Top
Rudrashekhar X Das

Posts: 11
Joined: 2006-05-22
I had the same issue when i migrated to the latest version of ADX for my excel addin. The registration directly from the VS2005 worked fine. Still unresolved.
Posted 28 Aug, 2006 16:37:25 Top
Brendon Colloty


Is it possible to manually register an add-in on a client machine?

How would i go about trying this?

I'm kind of at a loss as to what to try next as we have ub-installed and re-installed Office and even tried a repair install on Windows.

My next option seems to be a complete re-install of Windows which isn't going to make my clients happy :( just so they can get an outlook add-in to work :(


Posted 28 Aug, 2006 18:18:42 Top
Ralph Smith

Posts: 45
Joined: 2006-06-19

Just a few things to check out, as I know how fustrating the situation can be.

(i) According to MSDN your error may be...
"TargetInvocationException uses the HRESULT COR_E_TARGETINVOCATION which has the value 0x80131604"

I see a lot of those when my addin runs under the debugger. They do worry me, but something is catching and handling them. Some function is being called via reflection but that method doesn't exist or something of that sought. According to the docs, there should be an 'inner exception'. That would contain info on what really went wrong.

(ii) So does that user have the latest .NET installed and/or Outlook? Try checking that those are installed with the latest patches. I would even try installing the full .NET SDK on that machine just to be sure, if that's an option.

Hope that helps.

PS. Do you know how to excess the active ADXOlForm from the ADXOlFormsManager or ExplorerCommandBar handlers by any chance? :)
Posted 29 Aug, 2006 00:59:33 Top
Sergey Grischenko

Add-in Express team

Posts: 7233
Joined: 2004-07-05
Hi Brendon.

To register the add-in manually please use the following command line:
regsvr32.exe adxloader.dll.
The adxloader.dll.manifest file and all dependent assemblies should be placed in the same folder.
As to the registration error, probably you didn't include some assemlies that were required for the add-in.
Posted 29 Aug, 2006 07:04:21 Top
Lars Hjort

Posts: 5
Joined: 2005-09-29
Hi Sergey

Please help
I've tried almost everything. I started of with having the problem with framework 2.0 and Word.
That's been fixed by serveral hours of hairripping trial and error.

My problem has always been with the registration/installation of my addin.
I have worked many different versions of my addin and of "addinexpres", due to the problem with framework 2.0 (and bugfixes). The first versions of my addin have been installed via the Active Directory with Group Policy MSI installation.
But now I've ended up with serveral computers with 2 versions of the addin installed at the same time, resulting in no of the two version are working.
I've tried with and without the loader.
Either way I ended up with a installed version of the Addin, but it didn't show up in word, or it showed up - but disabled.
Finally I've had it with MSI and read the forum for the manual install procedure and last week I tried the installutil [targetdir] and so on. And it worked:
I made a version of my dll, renamed all my AddinCommandbars, so that I could have 2 version of the addin running at the same time.
Then, when the user start word, I test if the old commandbar is running, and I programmaticly delete it.
I use VBscript and .bat to copy the files locally: MyAddin.dll AddInExpress.MSO.2005.dll
I use gacutil (v.2.0) to put them all in the GAC and finally I use installutil (v.2.0) to install it.
This works on 90% of my companys pc.
But there are some that just won't work. Then I read this post sayin to use my loader (which I made for an earlier version of an MSI installpackages) and that doesn't work either.
What to do?

Posted 29 Aug, 2006 10:21:46 Top
Sergey Grischenko

Add-in Express team

Posts: 7233
Joined: 2004-07-05
Hi Lars.

I think you need to have the same product code for both add-ins to prevent the user from installing a new version of the add-in if the old one is currently installed on the PC. What do you think?
Posted 31 Aug, 2006 14:53:55 Top
Greg Ferber

Posts: 9
Joined: 2006-09-08
I'm getting the same error. Either the -214xxxxxx when Outlook loads, or 0x80131604 when trying to use regsvr32. But it only happens on some machines... Is there a list of dependencies/registry entries/whatever that Add-in-express needs to be in certain places in order to work? With that, I could at least manually check these machines. I thought a -214 was a file not found? Is there a version of the loader that will say what file isn't being found?
Posted 14 Feb, 2007 19:33:14 Top
Sergey Grischenko

Add-in Express team

Posts: 7233
Joined: 2004-07-05
Hi Greg?

Please upgrade the Add-in Express product up to v3.2. Then please look at the adxloader.log file to get more detailed information about the error
(.\My Documents\Add-in Express\adxloader.log)
Posted 15 Feb, 2007 11:52:31 Top