Problem with Internet Explore 10 when i set "handleHTTPNegotiations" and "handleDocumentUICommands" attributes values to True.

Add-in Express™ Support Service
That's what is more important than anything else

Problem with Internet Explore 10 when i set "handleHTTPNegotiations" and "handleDocumentUICommands" attributes values to True.
If i set "handleHTTPNegotiations" and "handleDocumentUICommands" values to true then some images get disappears in Internet Explorer ver-10. 
Rajeev Rajeevlochan Phadke




Posts: 11
Joined: 2014-02-11
We are setting "handleHTTPNegotiations" and "handleDocumentUICommands" attributes values to "True" for firing the event of "IEModule_OnDataAvailable". Because of these attributes set to true we are facing a problem. An image bar(which appears dynamically after selecting a check box) on a webpage vanishes.

The issue occurs only in Internet Explorer 10(Not checked with IE -11).

In IE-9 it works fine in all conditions.

Below are reference images
1. Before selecting checkbox
https://www.dropbox.com/s/t37s0n1grjrv9sb/Normal.png

After Selecting Checkbox in IE - 10
1.The above mentioned flags set to true
https://www.dropbox.com/s/ak51o1pla39sqnb/CheckBoxSelectedWithFlagsTrue.png

2.The above mentioned flags set to false
https://www.dropbox.com/s/wue9f1mjxbzwzui/CheckBoxSelectedWithFlagsFalse.png
Posted 20 Mar, 2014 06:12:29 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Rajeev,

Do you have any code in the IEModule_OnDataAvailable event handler?
Posted 20 Mar, 2014 06:48:06 Top
Rajeev Rajeevlochan Phadke




Posts: 11
Joined: 2014-02-11
Yes,we have IEModule_OnDataAvailable event handler.I have tried with simple project in which there is no IEModule_OnDataAvailable event handler but having handleHTTPNegotiations" and "handleDocumentUICommands" attributes value to True,it gives same problem.We need IEModule_OnDataAvailable event handler in our code to perform some action on Internet Explore.
Posted 20 Mar, 2014 23:55:14 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Rajeev,

What url can I use to reproduce the issue?
Posted 21 Mar, 2014 06:34:22 Top
Rajeev Rajeevlochan Phadke




Posts: 11
Joined: 2014-02-11
Hi Sergey Grischenko,

The URL and credentials belongs to one of our customer portal. so please let me know your email id, wherein I can send you the credentials.
Posted 24 Mar, 2014 08:20:12 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Rajeev,

I have just sent you an e-mail. Please check your inbox.
Posted 24 Mar, 2014 11:09:47 Top
Rajeev Rajeevlochan Phadke




Posts: 11
Joined: 2014-02-11
Hi Sergey Grischenko,

I have sent an e-mail with attached BHO_Toolbox_Issue.pdf.Have you seen the problem? Let me know the feedback for the problem.
Posted 28 Mar, 2014 01:24:32 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Rajeev,

Sorry, I can't find your email in my inbox. Please try to re-send it again. Or just send the document on the support e-mail.
Posted 28 Mar, 2014 11:13:00 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Rajeev,

Did you re-send the URL and credentials?
Posted 31 Mar, 2014 13:05:04 Top