How to debug the DllRegisterServer?

Add-in Express™ Support Service
That's what is more important than anything else

How to debug the DllRegisterServer?
Delphi VCL - How to debug the DllRegisterServer? 
GKoehn




Posts: 37
Joined: 2009-03-23
On my Machine that has Office 15 32-bit, I can use the Delphi 10 Seattle "ActiveX Server Register" command just fine. It works great.

I have a Machine that has Office 16 64-bit and the Delphi 10 Seattle "ActiveX Server Register" command fails.

How can I debug this to see what is failing?

How do I setup my Delphi as to set break points inside "function DllRegisterServer"?
Posted 20 Mar, 2017 17:41:27 Top
GKoehn




Posts: 37
Joined: 2009-03-23
I just tried a new addin for Word.
I have the same issue.

I am using Microsoft Office Professional Plus 2016.
It says "Updates are automatically downloaded and installed.".
It is Word Version 16.0.4266.1003.

In Delphi - Project Options - Host Application, I put "C:\Program Files\Microsoft Office\root\Office16\WINWORD.EXE".

I started Delphi 10 Seattle as Administrator.
I have the "Target Platforms" = 64-bit Windows.

I am following the document titled "Add-in Express for Microsoft Office and Delphi VCL Developer's Guide".
Page 14 instructions.
I have set the "Supported Apps" to ohaWord.

My OS is Windows 10 Pro, Version 1607, OS Build 14393.953.

How can I find the Issue?
Posted 20 Mar, 2017 19:32:36 Top
GKoehn




Posts: 37
Joined: 2009-03-23
I was able to create an Outlook 2016 64-bit Addin.
I then went to "Manage Addins" in Outlook and manually added my 64bit dll.
It worked.
I then tried to debug it in the Delphi 10 ide after doing this manual step.
Debugging worked.

However the Delphi - "ActiveX Server" - Register does not work on this computer.
Posted 20 Mar, 2017 20:20:18 Top
Dmitry Kostochko


Add-in Express team


Posts: 2731
Joined: 2004-04-05
Hi Gregory,

Please have a look at the Registering a COM Object article.

Note: The IDE, being a 32-bit process, cannot register 64-bit in-proc/DLL servers (32-bit processes cannot load 64-bit DLLs). To register 64-bit in-proc servers, you must use the 64-bit version of TRegSvr.exe, located in $(BDS)\bin64\TRegSvr.exe.


BTW, I have never used the bin64\TRegSvr.exe tool, the good old regsvr32.exe works fine for x64 libraries.
Posted 21 Mar, 2017 04:32:05 Top