ClickOnce install error

Add-in Express™ Support Service
That's what is more important than anything else

ClickOnce install error
 
malik




Posts: 63
Joined: 2009-10-21
Hi,

We are using the Outlook 2007, Win xp SP3 and Addin Express version 6.3.3052.0.
While installing from the click Once installer I am getting exception stating
"Can't find the 'CMP.Outlook' product in the system registry."

Please let me know what could be the cause?

Thanks,
Malik Z.
Posted 12 Apr, 2011 20:45:13 Top
Eugene Astafiev


Add-in Express team


Posts: 8540
Joined: 2007-07-25
Hi Malik,

First of all please note that you use an old build of Add-in Express 2010. You can download the latest build from our web site. Then please don't forget to replace the adxloader.dll in the Loader folder of your project with a new one (see the Redistributables folder).

Are you able to reproduce the issue with a newly created add-in project?
.NET, Extended MAPI, Windows Phone & RT
Posted 13 Apr, 2011 06:36:55 Top
malik




Posts: 63
Joined: 2009-10-21
Hi Eugene,

Thanks, I will try with new build.

I am not able to produce this error with newly created project, do I still need to use the new buid of Addin Express 2010 in my project?

Please let me know.

Thanks,
Malik Z.
Posted 13 Apr, 2011 09:28:59 Top
Eugene Astafiev


Add-in Express team


Posts: 8540
Joined: 2007-07-25
Hi Malik,

Did you modify or generate the ClickOnce installer manually (using the mage.exe utility)?

It looks like the cause of the issue you faced with lies in your add-in project (doesn't come from Add-in Expres). Please try to install a new build and then re-generate the ClickOnce installer. Does it help?
.NET, Extended MAPI, Windows Phone & RT
Posted 13 Apr, 2011 11:53:02 Top
malik




Posts: 63
Joined: 2009-10-21
Hi Eugene,

I tried with the new build (6.4.3056.0) as well and getting the same exception. I don't generate the installer manually, I create using the Publish wizard.

I cleared all my installation files and looked registry and it is clear (\HKey_Current_USER\Software\Microsoft\Office\Outlook)

I tried installing from Click Once applicaiton .application file it throws "Can't find the 'CMP.Outlook' product in the system registry."

I can see the files in the location "C:\Documents and Settings\malik\Application Data\My ClickOnce Applications" and "C:\Documents and Settings\malik\Local Settings\Apps\2.0"

When I tried again installing the click once install (.application file) it asked for register by clicking it said registered successfully by clicking OK it throws message "Object reference not set to an instance of an object." and this time I see entry in registry as well and in Add\Remove Program it shows my project name with "- 1" appended.

I updated the loader .dll files in the local project. what could be the issue?

Thanks,
Malik Z.
Posted 13 Apr, 2011 12:20:01 Top
Eugene Astafiev


Add-in Express team


Posts: 8540
Joined: 2007-07-25
Hi Malik,

It looks like you didn't remove the previous version of your add-in. Am I right?
.NET, Extended MAPI, Windows Phone & RT
Posted 13 Apr, 2011 13:14:14 Top
malik




Posts: 63
Joined: 2009-10-21
No, I removed everything from add/remove program and cleared all the installation folder content before installing the new Addin from click once.
Posted 13 Apr, 2011 13:38:22 Top
Eugene Astafiev


Add-in Express team


Posts: 8540
Joined: 2007-07-25
Hi Malik,

Are you able to reproduce the issue on another PC?
.NET, Extended MAPI, Windows Phone & RT
Posted 14 Apr, 2011 03:37:50 Top
malik




Posts: 63
Joined: 2009-10-21
Hi Eugene,

Yes, it is reproducable on the other development machine for the same application project.

Thanks,
Malik Z.
Posted 14 Apr, 2011 08:55:08 Top
Eugene Astafiev


Add-in Express team


Posts: 8540
Joined: 2007-07-25
Hi Malik,

Could you please send your project to the support e-mail address (see readme.txt for details)? I will take a look at it.
.NET, Extended MAPI, Windows Phone & RT
Posted 14 Apr, 2011 08:58:46 Top