Problem registering AddinModule for Word

Add-in Express™ Support Service
That's what is more important than anything else

Problem registering AddinModule for Word
AddinModule registers with installutil.exe but does not show in Word 
Guillaume Aimetti


Guest


Hey, I am writing an addin for Microsoft Word. I am having trouble running the addin module when trying to install the software onto another PC.

On my dev PC it works absolutely fine. I register the addin using installutil.exe and I am using AddinExpress.MSO.2005.dll. My addin also works fine when I use it other dev PC's but not when I try to install it on a clean PC?

My addin registers but then when I try to run it doesn't work. The Macros is set to low and it is not present in the disabled items?

Any ideas?

Thanks, Guy
Posted 29 Jan, 2007 04:00:37 Top
Sergey Grischenko


Add-in Express team


Posts: 7235
Joined: 2004-07-05
Hi Guillaume.

Did you install the 'Shared Add-in Support Update for .NET Framework v2.0' prerequisite on the clean PC?


P.S. Note that we take up your forum requests in the order we receive them.
Besides, it may take us some time to investigate your issue. Please be sure we will let you know as soon as the best possible solution is found.
Posted 29 Jan, 2007 07:05:58 Top
Guillaume Aimetti


Guest


Have sorted the problem! I needed a Winword.exe.config file to tell Word what version of the .NET framework it can work with.

Thanks for your help and quick reply,

Guillaume
Posted 29 Jan, 2007 10:44:11 Top
Sergey Grischenko


Add-in Express team


Posts: 7235
Joined: 2004-07-05
Ok, but please remember that the config file can prevent other managed add-ins from loading if they are written for different version of the .NET Framework.
Posted 29 Jan, 2007 16:30:24 Top