Installer needs new package code?

Add-in Express™ Support Service
That's what is more important than anything else

Installer needs new package code?
 
Maurice Calvert




Posts: 81
Joined: 2008-09-12
When I install ADX for IE, I get

The following properties have been set:
Property: [AdminUser] = true {boolean}
Property: [ProcessorArchitecture] = AMD64 {string}
Property: [VersionNT] = 6.1.0 {version}
Launching Application.
Using MsiInstallProduct with package path 'E:InstallAddinExpressIEdxienet-v604-b379-vs-pre.msi' and command line ''
MsiInstallProduct returned '1638'
Error:

according to MS this means you need to build it with a new package code.

Or did I miss something?

EDIT
I turns out that it was the package code, I had an old version of ADX for IE, but as the package code was the same it didn't say "A version of the program is already installed".

It would probably be a good idea to upd ate the package code at each release and set "remove previous versions"?

(In the se tup, increment the release number and answer "yes" to the "do you want to create a new upgrade code?")
Posted 15 Jan, 2011 08:38:31 Top
Sergey Grischenko


Add-in Express team


Posts: 7202
Joined: 2004-07-05
Hi Maurice.

Thank you for the suggestion. We will investigate the issue.
Posted 17 Jan, 2011 06:02:35 Top