IE10 embedded WebBrowser textboxes

Add-in Express™ Support Service
That's what is more important than anything else

IE10 embedded WebBrowser textboxes
 
Brett Lefebvre




Posts: 7
Joined: 2012-10-01
in IE10 with a WebBrowser control embedded in an ADXIEAdvancedBar it is very hard to get textboxes on a webpage in the WebBrowser to accept input. This works fine in IE9 and below.

Also, in all browsers tabbing through fields doesn't work in the WebBrowser control.
Posted 01 Oct, 2012 14:12:05 Top
Sergey Grischenko


Add-in Express team


Posts: 7202
Joined: 2004-07-05
Hi Brett,

What version of Add-in Express for IE do you use?
Posted 02 Oct, 2012 06:24:44 Top
Sergey Grischenko


Add-in Express team


Posts: 7202
Joined: 2004-07-05
Brett, Add-in Express doesn't provide the native support for WebBrowser Control. We will try to add it in subsequent builds of the product. What do you mean saying 'it is very hard to get textboxes on a webpage in the WebBrowser to accept input'? How can I reproduce this issue?
Posted 02 Oct, 2012 08:05:03 Top
Brett Lefebvre




Posts: 7
Joined: 2012-10-01
Using version 8.1.5065.

We've been using the windows forms WebBrowser control for some time now, and you guys have fixed issues with how it works with add in express in the past.

It appears to be a focus issue of some sort. If you have a WebBrowser control in a sidebar and have it open a page with textboxes on it for some reason it is very hard to get those textboxes to accept input. I was able to get it to work by clicking around between the main IE window and the extension sometimes.

This is a big issue for us, as it doesn't allow people to login in when using IE10.
Posted 02 Oct, 2012 11:16:39 Top
Sergey Grischenko


Add-in Express team


Posts: 7202
Joined: 2004-07-05
Hi Brett,

I can't reproduce the issue with textboxes in IE10. What the web page do you open in WebBrowser control?
Posted 03 Oct, 2012 04:58:31 Top
Brett Lefebvre




Posts: 7
Joined: 2012-10-01
I made a project that you can download. The project is using the add in express registration page. I was able to reproduce the issue on multiple computers.
Posted 04 Oct, 2012 12:28:16 Top
Sergey Grischenko


Add-in Express team


Posts: 7202
Joined: 2004-07-05
Hi Brett,

Thank you for the project. I managed to reproduce the issue.
I will investigate it and let you know about results as soon as possible.
Posted 05 Oct, 2012 04:34:49 Top
Sergey Grischenko


Add-in Express team


Posts: 7202
Joined: 2004-07-05
Hi Brett,

I fixed the issue with the Tab key in advanced bars. I can send you the hotfix by email if you wish.
As to the textboxes, now I don't know why it happens in IE10 only. But I have a workaround.
Could you please replace 'System.Windows.Forms.WebBrowser' control with the 'AxSHDocVw.AxWebBrowser' one. It is an ActiveX edition of the browser. I tested it in Win8 + IE10. It worked fine.
You can add AxSHDocVw.AxWebBrowser via the 'Toolbox->Choose Items...' dialog.
Posted 08 Oct, 2012 04:39:26 Top
Brett Lefebvre




Posts: 7
Joined: 2012-10-01
Email works for me. I will try out the AxWebBrowser also. Will let you know if I run into anything.

Thanks Sergey.
Posted 08 Oct, 2012 19:14:06 Top
Sergey Grischenko


Add-in Express team


Posts: 7202
Joined: 2004-07-05
Hi Brett,

I have just sent you an email. Please check your inbox.
Posted 12 Oct, 2012 05:25:05 Top