Insallation Problem

Add-in Express™ Support Service
That's what is more important than anything else

Insallation Problem
AddIn is not shown in Excel 
Michael Kaden




Posts: 251
Joined: 2017-11-15
Dear Andrei,

I tried the installation several times an it works very good. I even installed it without de-installing the installed version. But the client now gets

User added an image

Can you help?

Thank you & kind regards

Michael
Posted 15 Oct, 2019 12:13:42 Top
Andrei Smolin


Add-in Express team


Posts: 16956
Joined: 2006-05-11
Michael Kaden writes:
But it still writes to AppData/Temp/alera Thermal/adxloader.log


Make sure you rebuild the add-in project and setup project and that you run the newest instaler. When it get installed, check the manifest it deploys.

Michael Kaden writes:
But the client now gets


Check https://stackoverflow.com/questions/41720158/unable-to-install-error-0x80070643-failed-to-install-msi-package. A bit of extra info: the below is how I suggest creating the log file they mention on that page:


I suggest that you run the installer using MSIEXEC.EXE started from a Command Prompt (elevated if you run the installer elevated) with these parameters: msiexec.exe /L*v log.txt /i {MSI file name}.msi. This will generate the log.txt file which may provide extra info.


Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 16 Oct, 2019 02:10:02 Top
Michael Kaden




Posts: 251
Joined: 2017-11-15
Dear Andrei,

thank you, I just send an email with report attachments and screen prints to support on the subject.

kind regard

Michael
Posted 16 Oct, 2019 10:24:37 Top
Andrei Smolin


Add-in Express team


Posts: 16956
Joined: 2006-05-11
Hello Michael,


Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel.


You need to uninstall the existing version. On my development machine this occurs in the following scenario:
1) I build a setup project and install the product
2) I modify the setup project (this changes ProductCode)
3) I run the new installer (without uninstalling the old one)

<loaderSettings generateLogFile="true" shadowCopyEnabled="false" privileges="user" minOfficeVersionSupported="14" />


There's no path to the loader log specified. This is why the loader writes the log file to the default location.

Did you restart that machine as suggested on that page? The error you reported earlier may be an indication of the system being in a state that requires restarting it.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 17 Oct, 2019 09:24:44 Top
Michael Kaden




Posts: 251
Joined: 2017-11-15
Dear Andrei,

unfortunately we are still battling with the issue. I send an email with some log files and more information to support just now.

hope you can help

Thank you & kind regards

Michael
Posted 30 Oct, 2019 05:11:28 Top