Add-In deactivated after Outlook restart

Add-in Express™ Support Service
That's what is more important than anything else

Add-In deactivated after Outlook restart
 
wehbi




Posts: 73
Joined: 2013-10-31
Thanks for the PDF hint, I will have a deeper at it look later on.
The adxloader.log is only written when I activate the add-in while Outlook is running. There is no adxloader.log when I simply start Outlook with deactivated add-in.

Below the adxloader.log, after starting the add-in while Outlook is running (looks fine I think):

Add-in Express Loader Log File: 01/12/2016 08:40:07:913

Startup directory: C:\DEVELOPMENT_SPACE\Workspace\Visual_Studio_2015\cs4o\com.befine-solutions.cs4o.cs4outlook\bin\Debug\
Loader version: 8.0.4330.0
Operating System: Microsoft Windows 7 Professional Service Pack 1 (build 7601), 64-bit
Process Owner: Administrator
Command Line: "C:\Program Files (x86)\Microsoft Office\root\Office16\OUTLOOK.EXE"
Run 'As Administrator': Yes
Process Elevated: Yes
Integrity Level: High
UAC (User Account Control): On
------------------------------------------------------------------------
08:40:07:914 14940 11360 Start.
08:40:07:914 14940 11360 Creating a new instance of the add-in loader.
08:40:07:914 14940 11360 Loading mscoree.dll
08:40:07:914 14940 11360 Success.
08:40:07:914 14940 11360 Loading the configuration from the system registry.
08:40:07:915 14940 11360 Getting the latest CLR version.
08:40:07:915 14940 11360 The latest CLR version is 'v4.0.30319'.
08:40:07:915 14940 11360 The configuration has been loaded successfully.
08:40:07:915 14940 11360 Runtime version: v4.0.30319.
08:40:07:915 14940 11360 Assembly name: com.befine_solutions.cs4outlook, PublicKeyToken=1187CD08DAAA84EA.
08:40:07:915 14940 11360 Class name: com.befine_solutions.cs4outlook.AddinModule.
08:40:07:915 14940 11360 Registry key: CLSID\{8F4904E8-B320-4280-BA03-2EB5A9641AAA}.
08:40:07:915 14940 11360 Attempting to create a new instance of the managed add-in class: CLR - v4.0.30319
08:40:07:915 14940 11360 Loading CLR: v4.0.30319.
08:40:07:915 14940 11360 Calling CLRCreateInstance method.
08:40:07:915 14940 11360 Success.
08:40:07:916 14940 11360 Calling GetRuntime method.
08:40:07:916 14940 11360 Success.
08:40:07:916 14940 11360 Checking if the hosting API of .NET Framework v4.0 beta is installed.
08:40:08:567 14940 11360 The hosting API is up to date.
08:40:08:567 14940 11360 Calling GetInterface method for the CorRuntimeHost interface.
08:40:08:567 14940 11360 Success.
08:40:08:567 14940 11360 Starting CLR...
08:40:08:567 14940 11360 Success.
08:40:08:567 14940 11360 Getting the CLR version.
08:40:08:567 14940 11360 The CLR v4.0.30319 has been initialized successfully.
08:40:08:649 14940 11360 Creating a new domain setup.
08:40:08:650 14940 11360 Success.
08:40:08:650 14940 11360 Getting the add-in directory.
08:40:08:650 14940 11360 Success. The directory is 'C:\DEVELOPMENT_SPACE\Workspace\Visual_Studio_2015\cs4o\com.befine-solutions.cs4o.cs4outlook\bin\Debug\'
08:40:08:650 14940 11360 The configuration file is 'C:\DEVELOPMENT_SPACE\Workspace\Visual_Studio_2015\cs4o\com.befine-solutions.cs4o.cs4outlook\bin\Debug\com.befine_solutions.cs4outlook.dll.config'
08:40:08:650 14940 11360 The 'shadow copy' is disabled.
08:40:08:650 14940 11360 Creating a new application domain.
08:40:08:654 14940 11360 Success.
08:40:08:654 14940 11360 Creating an instance of the managed class. Assembly identity: 'com.befine_solutions.cs4outlook, PublicKeyToken=1187CD08DAAA84EA'
08:40:09:262 14940 11360 Success.
08:40:09:262 14940 11360 Unwrapping the managed class.
08:40:09:276 14940 11360 Success.
08:40:09:276 14940 11360 Querying the add-in extensibility.
08:40:09:276 14940 11360 Success.
08:40:09:276 14940 11360 Querying the custom task panes.
08:40:09:276 14940 11360 Success.
08:40:09:276 14940 11360 Querying the ribbon extensibility.
08:40:09:276 14940 11360 Success.
08:40:09:276 14940 11360 Querying the form regions.
08:40:09:276 14940 11360 Success.
08:40:09:276 14940 11360 Querying the encryption provider.
08:40:09:276 14940 11360 The 'EncryptionProvider' interface is not supported.
08:40:09:276 14940 11360 Getting the dispid of the 'Dispose' method.
08:40:09:278 14940 11360 Success.
08:40:09:278 14940 11360 The instance of the managed add-in class has been created successfully.
Posted 12 Jan, 2016 09:42:59 Top
Andrei Smolin


Add-in Express team


Posts: 17125
Joined: 2006-05-11
Thank you.

In case you have the add-in installed and registered from the IDE, or both? Does the issue occur when you start Outlook by pressing {F5} while in the IDE or when you start Outlook from the Start menu?

Did you ever modify the RegisterForAllUsers property on the add-in module?

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 13 Jan, 2016 05:32:39 Top
wehbi




Posts: 73
Joined: 2013-10-31
Hello Andrei,

F5 didn't made any difference. I did also triggered the repair function of VS2015 and Office2016, but still not working.
I made a complete new installation of Office - tada! - it works again.

Thanks for your help!

Regards,
Birger
Posted 15 Jan, 2016 03:18:14 Top
Andrei Smolin


Add-in Express team


Posts: 17125
Joined: 2006-05-11
Thank you for letting me know.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 15 Jan, 2016 03:29:10 Top