Error when installing .NET Outlook Addin 1.1 on 2.0 machines

Add-in Express™ Support Service
That's what is more important than anything else

Error when installing .NET Outlook Addin 1.1 on 2.0 machines
 
Sergey Grischenko


Add-in Express team


Posts: 7235
Joined: 2004-07-05
Manuel, Add-in Express supports both versions of .NET Framework and you just need to build the add-in in the correct verion of Visual Studio.
Is it a problem for you?
Posted 05 Jul, 2006 12:34:08 Top
Brad Smith




Posts: 49
Joined: 2005-11-22
Manuel, my read is your problem is actually with the installer, not the actual add-in. If that's so you're probably getting bitten by the stuff under "Potential hotspots" in the aforementioned article.

Your short term solution might be to write your own installer that doesn't use the AddinExpress.Install.dll module. I think Sergey posted info here just recently that might help.

One could argue that they *could* test & fix AddinExpress.Install.dll so that it dances around the hotspots, but since that'd take time away from implementation of new features, or more pressing fixes; combined with the fact that installing 1.1 add-ins on a 2.0-only system is relatively rare; I can't imagine that being a popular option.

In my experience (outside the whole add-in thing), 1.1 and 2.0 are incompatible enough that you'll spend huge amounts of time tracking down annoying buglets. So far, in every case like yours that I've heard about, the developers ended up surrendering and upgrading to VS 2005 and .NET 2.0, or sticking with 1.1 and insisting the customers have it. That's the approach I took with my company's products. The old version requires 1.1 and I won't support a 2.0-only environment; and the new version requires 2.0. So far that approach hasn't caused any concerns.

Brad.
Posted 05 Jul, 2006 12:45:14 Top
S Manuel




Posts: 10
Joined: 2006-07-04
Brad,

you are right. The Installation of the Addin fails and the big question is: Why does AddinExpress.Install fail with an ApplicationException on 2.0...?

I've already thought about using a different Installation method. But I think I will end up in rebuilding the AddIn on VS2005/2.0; providing a Package for .NET 1.1 and one for 2.0 separately.
(Anyway, even if I manage to get it installed by using another method, I am sure that I will experience some really strange problems on some clients and so I agree with you and Sergey about the fact that 2.0 is not really compatible with 1.1.)

Since most (>85%) of our customers run 1.1 there is now way at the moment to force them all to move to 2.0. On the other hand the rest is using 2.0 only and does not want to install "old things"... ;-)

May be in a few months .NET 2.0 is "automatically" present on every client and this hopefully will not be a problem anymore.

Thanks to you all for your feedback.
Manuel
Posted 05 Jul, 2006 13:44:23 Top
Sergey Grischenko


Add-in Express team


Posts: 7235
Joined: 2004-07-05
Brad, thank you for your collaboration in this subject.

Manual, now I am working on a special loader (something similar to the VSTO loader) for our add-ins and I hope it will solve the issue concerning 1.1 and 2.0 compatibility. I will let you know about results soon.
Posted 05 Jul, 2006 13:55:20 Top