Toolbar positioning in office addin continued

Add-in Express™ Support Service
That's what is more important than anything else

Toolbar positioning in office addin continued
Button disappears and reappears rapidly when typing an email 
Sergey Grischenko


Add-in Express team


Posts: 7229
Joined: 2004-07-05
Hi Ole Andreas.

I have a little example that shows on how you can prevent the custom Outlook menu from appearing in Word when Word is used as an editor in Outlook. You can download it here:
http://www.add-in-express.com/projects/wordinoutlook2.zip
Posted 14 Aug, 2006 15:34:15 Top
Ole Andreas Ringdal


Rather green-ish


Posts: 46
Joined: 2006-05-30
Hi Sergey,

Thanks a lot for the example. I found this on the website about a week ago, and while I do program in VB.Net exclusively, I do think I managed to sort out the CSharp-code. I also found the "wordinoutlookissue" zip-file -- what exactly is meant to be the difference between these two? (It's late and my logic fails me...)

Best regards,
//Ole Andreas
Posted 15 Aug, 2006 16:18:50 Top
Sergey Grischenko


Add-in Express team


Posts: 7229
Joined: 2004-07-05
Hi Ole Andreas.

These examples are different.
The 'wordinoutlookissue' example shows how you can prevent the 'Word Bar' toolbar from appearing in Outlook inspector if Word is used as an editor.
Posted 16 Aug, 2006 07:19:12 Top
Ryszard Krakowiak




Posts: 6
Joined: 2006-08-25

For some reason I don't have this issue on my PC even though the 'Windows in Taskbar' option is checked. Probably there is something else in Word that causes the issue. I will investigate it and will let you know about results soon.

I went into the same problem :)
If I have HandleShortcuts set to True im my add in, I receive mentioned issue.
This occurs only if I have "windows in taskbar" turned on.
Posted 25 Aug, 2006 09:59:26 Top
Ole Andreas Ringdal


Rather green-ish


Posts: 46
Joined: 2006-05-30
Bingo! Ryszard, you nailed it...

Loaded up an old version of my add-in which uses buttons on custom toolbars in Word, and set HandleShortcuts to False. Loaded up several documents (with "Windows in Taskbar" turned on), as well as also opening up a new email in Outlook (using Word as the email editor), and voila! No jumping or flickering or whatever in any of the windows. The toolbar is just sitting there nicely... As it should. :-)

Guess I'll have to live without the shortcut, but that's a minuscule sacrifice to make in order to have the toolbars functioning properly.

Many thanks!
//Ole Andreas
Posted 27 Aug, 2006 03:46:37 Top