Exception caused by BuiltInControl in Outlook AddIn

Add-in Express™ Support Service
That's what is more important than anything else

Exception caused by BuiltInControl in Outlook AddIn
 
Dmitry Kostochko


Add-in Express team


Posts: 2745
Joined: 2004-04-05
Hi Sam,

Strange...
Is your Outlook a client of MS Exchange?


Posted 23 Mar, 2005 13:03:30 Top
Sam Mulholland




Posts: 9
Joined: 2005-03-07
Strange indeed.

When I'm in the office the Outlook client connects to Exchange (5.5). When I'm at home Outlook is a regular mail client.

Here's another thing - I work on a regular workstation in the office, and a Sony Vaio at home. Compiling your test add-in on either machine and then attempting to use it in Outlook on either machine gives the same error message!

It's gotta be something!

Both Delphi installs (home and office) are configured identically. In the IDE I use GExperts, JVCL, Add-In Express, VCLZip and that's pretty much it. I can't imagine these would cause any problems?

I guess the fact that I can get the problem to happen on 2 machines means we should look at anything as a possible answer?

Sam.
Posted 24 Mar, 2005 03:54:15 Top
Dmitry Kostochko


Add-in Express team


Posts: 2745
Joined: 2004-04-05
Sam,

You are absolutely right, we should find the cause of the problem. Let's try to test the add-in without compiling it on your PC. I have just uploaded the whole zip file:
http://www.add-in-express.com/projects/adx-ol-built-in-bug.zip

Please try to register it via regsvr32.exe adxOLBuiltInBug.dll and try to add the DLL via the COM Add-ins dialog box. Looking forward to your results. Thank you in advance.


Posted 24 Mar, 2005 09:34:23 Top
Sam Mulholland




Posts: 9
Joined: 2005-03-07
Dmitry,

Your compiled add-in works perfectly. I registered it using both methods.

I still have not successfully registered your test add-in after compiling it myself.

Using a resource editor, I have noticed your compiled library contains the Delphi7 application icon? Can you compile it with 6 and send it through to me?

Sam.
Posted 30 Mar, 2005 15:40:29 Top
Dmitry Kostochko


Add-in Express team


Posts: 2745
Joined: 2004-04-05
Hi Sam,

Using a resource editor, I have noticed your compiled library contains the Delphi7 application icon?

This happens because I have created the project in Delphi 7. But DLL I uploaded for you was compiled in Delphi 6.

Can you compile it with 6 and send it through to me?

See this project. It was created and compiled in Delphi 6.
http://www.add-in-express.com/projects/adx-ol-built-in-bug-d6.zip

Posted 31 Mar, 2005 05:30:43 Top