Add-In deactivated after Outlook restart

Add-in Express™ Support Service
That's what is more important than anything else

Add-In deactivated after Outlook restart
 
wehbi




Posts: 73
Joined: 2013-10-31
Dear Add-In Express Team,

after a slightly problematic update of VS 2015, I'm not able to activate my add-in as default.
After starting Outlook the add-in can be activated and used with no restriction. When restarting Outlook, the add-in is deactivated again.
LoadBehavior is 3. When starting Outlook, no adx logs are written till I activate the add in manually, but the logs do not contain any error.

Thanks for your help.

Regards,
Wehbi
Posted 07 Jan, 2016 07:31:50 Top
Dmitry Kostochko


Add-in Express team


Posts: 2841
Joined: 2004-04-05
Hi Birger,

Does this happen on your (development) machine or on end user machines? If the former, try to unregister your add-in in all solution configurations (Debug, Release, etc.), clean the solution and then register your add-in anew. Also, do you have per-user or per-machine add-in?
Posted 08 Jan, 2016 04:34:25 Top
wehbi




Posts: 73
Joined: 2013-10-31
Hi Dmitry,

thanks for your response.
The problem appears on my development machine. I followed your instructions, but it seems not to work, in my case.
The scope is set to "per-machine".
It behaves, that the LoadBehavior is set to 0 at every startup.
After activating the add-in, everything is running fine till I restart Outlook.

Regards,
Birger
Posted 08 Jan, 2016 06:03:10 Top
Dmitry Kostochko


Add-in Express team


Posts: 2841
Joined: 2004-04-05
Hi Birger,

Please try to do the following:
1. Close Outlook
2. Open the Registry Editor and set LoadBehavior to 3 in both (HKLM and HKCU) registry hives.
3. Start Outlook and check if your add-in is loaded correctly.
4. Close Outlook and check the LoadBehavior value in both registry hives.

Please let me know about the results.
Posted 08 Jan, 2016 08:47:25 Top
wehbi




Posts: 73
Joined: 2013-10-31
Hi Dmitry,

sorry for the delay!
I'm wondering why the add-in has an entry in HKCU because it's distributed per-machine.
Never the less, I set both entries to 3, started Outlook and the add-in was still disabled. HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\cs4 outlook.Add in Module and HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\cs4outlook.AddinModule is still 3, after closing Outlook.
Is there another approach?

Thanks and kind regards,
Birger
Posted 12 Jan, 2016 02:36:24 Top
Andrei Smolin


Add-in Express team


Posts: 17132
Joined: 2006-05-11
Hello Birger,

wehbi writes:
I'm wondering why the add-in has an entry in HKCU because it's distributed per-machine.


Office creates such a key to let a user turn a per-machine off or on. Please export that key to a text file and post the file content here.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 12 Jan, 2016 05:28:17 Top
wehbi




Posts: 73
Joined: 2013-10-31
After unregister and register the add-in again, I've got the following keys:

###############################################################################
Schlüsselname: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Addins\cs4outlook.AddinModule
Klassenname: <KEINE KLASSE>
Letzter Schreibzugriff: 12.01.2016 - 08:37
Wert 0
Name: FriendlyName
Typ: REG_SZ
Daten: CS4O

Wert 1
Name: Description
Typ: REG_SZ
Daten: AddinModule

Wert 2
Name: LoadBehavior
Typ: REG_DWORD
Daten: 0x3

Wert 3
Name: CommandLineSafe
Typ: REG_DWORD
Daten: 0
###############################################################################
Schlüsselname: HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\cs4outlook.AddinModule
Klassenname: <KEINE KLASSE>
Letzter Schreibzugriff: 12.01.2016 - 08:40
Wert 0
Name: ADXStartMode
Typ: REG_SZ
Daten: NORMAL


Schlüsselname: HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\cs4outlook.AddinModule\ADXXOL
Klassenname: <KEINE KLASSE>
Letzter Schreibzugriff: 12.01.2016 - 08:40
Wert 0
Name: ExplorerolMailItemDockRight_State
Typ: REG_DWORD
Daten: 0x1


Schlüsselname: HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\cs4outlook.AddinModule\ADXXOL\ADXOlFormsCollectionItem0
Klassenname: <KEINE KLASSE>
Letzter Schreibzugriff: 12.01.2016 - 08:40

Schlüsselname: HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\cs4outlook.AddinModule\ADXXOL\ADXOlFormsCollectionItem1
Klassenname: <KEINE KLASSE>
Letzter Schreibzugriff: 12.01.2016 - 08:40

Schlüsselname: HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\cs4outlook.AddinModule\CommandBars
Klassenname: <KEINE KLASSE>
Letzter Schreibzugriff: 12.01.2016 - 08:40

Schlüsselname: HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\cs4outlook.AddinModule\CommandBars\Positions
Klassenname: <KEINE KLASSE>
Letzter Schreibzugriff: 12.01.2016 - 08:40

Schlüsselname: HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\cs4outlook.AddinModule\CommandBars\Positions\CryptshareSettings
Klassenname: <KEINE KLASSE>
Letzter Schreibzugriff: 12.01.2016 - 08:40
Wert 0
Name: Position
Typ: REG_DWORD
Daten: 0x1

Wert 1
Name: Left
Typ: REG_DWORD
Daten: 0xfffffff8

Wert 2
Name: Top
Typ: REG_DWORD
Daten: 0xfffffff8

Wert 3
Name: RowIndex
Typ: REG_DWORD
Daten: 0x6


Schlüsselname: HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\cs4outlook.AddinModule\Controls
Klassenname: <KEINE KLASSE>
Letzter Schreibzugriff: 12.01.2016 - 08:40
###############################################################################

Thanks for your help!
Birger
Posted 12 Jan, 2016 05:48:08 Top
Andrei Smolin


Add-in Express team


Posts: 17132
Joined: 2006-05-11
Thank you. This is exactly the key I mentioned: Office creates it to let the user turn the per-machine off; Add-in Express uses this key to store user-level settings of the add-in.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 12 Jan, 2016 05:56:20 Top
wehbi




Posts: 73
Joined: 2013-10-31
Hi Andrei,

so it seems that the registry keys are correct, right? Unfortunately the problem is still the same - when I activate the add-in, while Outlook is running, everything works fine. After restarting Outlook, the add-in is deactivated again.

What else can I do? The problem persists, since I cancelled a update of VS 2015.

Kind regards,
Birger
Posted 12 Jan, 2016 07:22:35 Top
Andrei Smolin


Add-in Express team


Posts: 17132
Joined: 2006-05-11
Restart Outlook, check that the add-in is deactivated and post here a copy of adxloader.log; please find details in section "Get details about add-in loading", see the PDF file in the folder {Add-in Express}\Docs on your development PC.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 12 Jan, 2016 09:27:30 Top