Outlook slow start

Add-in Express™ Support Service
That's what is more important than anything else

Outlook slow start
Outlook is slow to start after adding ADX extension 
Randolph Leigh




Posts: 5
Joined: 2005-06-04
I've created an Outlook ADX botton pane addin. Once installed in Outlook, it (outlook) is very slow to start. I have to press the Server request cancel option for Outlook in the system tray icon. (I am running remotely over a VPN connection.) This is not typical behavior and uninstalling the addin resolves the issue.

Suggestion?
Posted 29 Apr, 2006 17:32:11 Top
Sergey Grischenko


Add-in Express team


Posts: 7234
Joined: 2004-07-05
Hi Randolph.

Does Outlook start slowly if you run it locally? Or is it slow to start via VPN connection only?
Posted 01 May, 2006 14:05:27 Top
Randolph Leigh




Posts: 5
Joined: 2005-06-04
Will have to try in that scenerio. Will report results. Thanks Sergey.
Posted 02 May, 2006 00:02:57 Top
Randolph Leigh




Posts: 5
Joined: 2005-06-04
Yes it starts slow on both a direct connect and the VPN. I do have another Outlook addin in the installation that uses the Delphi toolkit.
Posted 05 May, 2006 23:51:09 Top
Randolph Leigh




Posts: 5
Joined: 2005-06-04
Removing the other addin did not make any difference.
Posted 05 May, 2006 23:53:01 Top
Todd Carlson




Posts: 29
Joined: 2006-05-07
Randolph & Sergey,
I am seeing the same behavior. What I have found is that my add-in will load in a normal amount of time, until I add an Outlook Forms Manager control. Once that control has been added and the add-in registered outlook will take 3-5 minutes to load. Without the outlook forms manager outlook will load in < 30 seconds.

Todd
Posted 08 May, 2006 09:16:56 Top
Sergey Grischenko


Add-in Express team


Posts: 7234
Joined: 2004-07-05
Hi Randolph and Todd.

I will try to reproduce this issue on my PC and will let you know about results ASAP.
Posted 08 May, 2006 11:24:30 Top
Todd Carlson




Posts: 29
Joined: 2006-05-07
Sergey,
It appears to be related to the number of items (both folders and mail items) in the store. In my test I have:
ExplorerItemType = Unknown
ExplorerLayout = WebViewPane
FolderName = "Todd Test"
FolderNames = ""

(nothing set for inspectors)

when I open my default profile, it takes 3-5 minutes. Opening a new profile with no messages and only a default set of folders it takes a "normal" amount of time to load.

Testing is being done with build 894.

todd
Posted 08 May, 2006 12:27:26 Top
Eugene Starostin


Guest


Todd,

What version of ADX Extensions do you use?
Posted 08 May, 2006 16:19:37 Top
Eugene Starostin


Guest


Please ignore my previous message. I see it is build 894.
Posted 08 May, 2006 16:20:20 Top