Shortcuts Not Working

Add-in Express™ Support Service
That's what is more important than anything else

Shortcuts Not Working
 
Mark Williams




Posts: 26
Joined: 2010-09-30
I can't get shortcuts to work in my addon. The problem started when I moved computers. I remember getting an error message about somthing being outdated in the project but I didn't write the error down and it hasn't come back.

Any idea what the problem could be?

HandleShortcuts is set to true by the way. I have tried deleting shortcuts, etc. and nothing has worked.
Posted 25 Oct, 2010 14:46:43 Top
Andrei Smolin


Add-in Express team


Posts: 15285
Joined: 2006-05-11
Hi Mark,

Try creating a new project and checking if shortcuts work in it.

Mark Williams wrote:
I remember getting an error message about somthing being outdated in the project


That message is shown if the versions of Loader\adxloader*.dll files in your project don't match that of {Add-in Express}\Redistributables\adxloader*.dll.

Regards from Belarus (GMT+2),

Andrei Smolin
Add-in Express Team Leader
Posted 26 Oct, 2010 01:42:22 Top
Mark Williams




Posts: 26
Joined: 2010-09-30
I created a new project and no luck on shortcuts. Any ideas?

I am using Ctrl+I as the test shortcut. It opens up the favorites sidebar. I've also tried Ctrl+F1 and Ctrl+1.

These worked on the old computer. I have tried repairing Add In Express and copying the new adxloaders into the project but that won't work either.

-HandleShortcuts is set to true
-OnAction is set for the keyboard shortcut - it doesn't fire
Posted 28 Oct, 2010 10:07:37 Top
Andrei Smolin


Add-in Express team


Posts: 15285
Joined: 2006-05-11
Hi Mark,

May I look at your AddinModule.cs (AddinModule.vb)? No code implementing business logics is required. Please send the file to the support e-mail address, see {Add-in Express}\readme.txt; make sure your e-mail contains a link to this topic.

Regards from Belarus (GMT+2),

Andrei Smolin
Add-in Express Team Leader
Posted 28 Oct, 2010 10:51:58 Top
Mark Williams




Posts: 26
Joined: 2010-09-30
Just shot you an email. Thanks for your help.
Posted 28 Oct, 2010 12:17:56 Top
Eugene Astafiev


Add-in Express team


Posts: 8540
Joined: 2007-07-25
Hi Mark,

Thank you for providing us with your add-in module.

I have reproduced the issue you described above with a newly created add-on project. It looks like the Ctrl+Delete key combination is a reserved keyboard hotkey in Internet Explorer. When and why do you wnat to use it?

Instead I would suggest using another key combination (such as Ctrl+E, for example).
.NET, Extended MAPI, Windows Phone & RT
Posted 29 Oct, 2010 10:12:54 Top
Mark Williams




Posts: 26
Joined: 2010-09-30
None of the keys work - that was just the last one I tried. I can't get anything to work - Ctrl+1, Ctrl+I - nothing. Not one type of shortcut will work.
Posted 29 Oct, 2010 13:17:20 Top
Eugene Astafiev


Add-in Express team


Posts: 8540
Joined: 2007-07-25
Hi Mark,

Did you set up the HandleShortcuts property of the add-on module to true?
.NET, Extended MAPI, Windows Phone & RT
Posted 02 Nov, 2010 08:11:46 Top
Mark Williams




Posts: 26
Joined: 2010-09-30
Yes - as stated earlier - that is set to true.
Posted 02 Nov, 2010 08:23:00 Top
Eugene Astafiev


Add-in Express team


Posts: 8540
Joined: 2007-07-25
Hi Mark,

It looks like you use reserved shortcuts in Internet Explorer.

I have just tested the Ctrl+C shortcut on my PC with Internet Explorer 8. Does it work for you? If not, please send a sample add-on project to the support e-mail address (see readme.txt for details). I will test it on my PC.
.NET, Extended MAPI, Windows Phone & RT
Posted 02 Nov, 2010 10:32:20 Top