Specifying .NET Framework version 1.1 over 2.0

Add-in Express™ Support Service
That's what is more important than anything else

Specifying .NET Framework version 1.1 over 2.0
 
Jon Schmoll




Posts: 5
Joined: 2006-03-21
I have a C# add-in for MS Project that uses the 1.1 Framework. We'll eventually update it to 2.0, but I currently need to use the older version. Using Add-in Express, can I specify which version of the .NET Framework I want to use?
Posted 21 Mar, 2006 10:33:22 Top
Sergey Grischenko


Add-in Express team


Posts: 7235
Joined: 2004-07-05
Hi Jon.

I found your question without our feedback. Sorry for delay.

You will have to rebuild your add-in for .NET Framework v2.0. You should use the AddinExpress.MSO.2005.dll assembly instead of the AddinExpress.MSO.dll one. However you can use the shared code. You just need to add all existing code in a new VS2005 add-in project using the 'Add as Link' option of the 'Add Existing Item' dialog.


Posted 16 May, 2006 11:55:23 Top