"The parameter is incorrect" when registering ADX plugin

Add-in Express™ Support Service
That's what is more important than anything else

"The parameter is incorrect" when registering ADX plugin
"The parameter is incorrect" when registering ADX plugin 
Alex DeNeui




Posts: 9
Joined: 2008-10-09
Hi there -

On a few machines, we've gotten into a state where a freshly installed plugin will not run. If we uninstall and reinstall it still fails to work. Here is our ADX loader log file. Ideas?

Thanks,
alex


Add-in Express Loader Log File: 10/21/2010 14:34:15

Startup directory: C:\Program Files\XXX\
Loader version: 6.0.3038
------------------
14:34:15 596 2832 Start.
14:34:15 596 2832 Reading the registry key 'HKEY_CLASSES_ROOT\CLSID\{AB05E127-11DD-47F8-B17D-25C071063CEC}'
14:34:15 596 2832 Success. The registry key 'HKEY_CLASSES_ROOT\CLSID\{AB05E127-11DD-47F8-B17D-25C071063CEC}' is closed.
14:34:15 596 2832 Converting the '{4BA250A6-8BCA-46A6-982A-F340081187C3}' CLSID from string.
14:34:15 596 2832 Success.
14:34:15 596 2832 Attempting to get the class object by the '{4BA250A6-8BCA-46A6-982A-F340081187C3}' CLSID.
14:34:15 596 2832 Success.
14:34:15 596 2832 Creating a new instance of the add-in loader.
14:34:15 596 2832 Success.
14:34:15 596 2832 Loading the configuration from the system registry.
14:34:15 596 2832 Getting the latest CLR version.
14:34:15 596 2832 The latest CLR version is 'v2.0.50727'.
14:34:15 596 2832 The configuration has been loaded successfully.
14:34:15 596 2832 Runtime version: v2.0.50727.
14:34:15 596 2832 Assembly name: XXX, PublicKeyToken=7CC7251DDF65F816.
14:34:15 596 2832 Class name: XXX.
14:34:15 596 2832 Attempting to create a new instance of the managed add-in class: CLR - v2.0.50727
14:34:15 596 2832 Loading CLR: v2.0.50727.
14:34:15 596 2832 The CLR v2.0.50727 has been initialized successfully.
14:34:15 596 2832 Creating a new domain setup.
14:34:15 596 2832 Success.
14:34:15 596 2832 Getting the add-in directory.
14:34:15 596 2832 Success. The directory is 'C:\Program Files\XXX\'
14:34:15 596 2832 The configuration file is ''
14:34:15 596 2832 The 'shadow copy' is enabled.
14:34:15 596 2832 Creating a new application domain.
14:34:15 596 2832 Success.
14:34:16 596 2832 The parameter is incorrect.
Posted 21 Oct, 2010 16:55:31 Top
Eugene Astafiev


Add-in Express team


Posts: 8540
Joined: 2007-07-25
Hi Alex,

The log states that you use an old build of Add-in Express. Please try to install the latest build and then replace the adxloader[64].dll in the Loader folder of your project with a new one.

Please let me know whether it works for you.
.NET, Extended MAPI, Windows Phone & RT
Posted 22 Oct, 2010 01:57:47 Top
Alex DeNeui




Posts: 9
Joined: 2008-10-09
Yes... it was due to an old version.

Thanks,
alex
Posted 28 Oct, 2010 17:25:17 Top
Eugene Astafiev


Add-in Express team


Posts: 8540
Joined: 2007-07-25
Hi Alex,

Good news! Thank you for letting me know.
.NET, Extended MAPI, Windows Phone & RT
Posted 29 Oct, 2010 06:01:36 Top