Add-In does not load anymore

Add-in Express™ Support Service
That's what is more important than anything else

Add-In does not load anymore
 
Andreas Lipphardt




Posts: 51
Joined: 2008-12-19
Hi Support,

I am on Addin Express 2010. Each time I rebuild my project my Excel Add-In does not load anymore.
To make it work again I have to rebuild and install an new setup.

Un- and re-registering the Add-In does not fix the problem

Any idea whats wrong here?


Andreas
Posted 28 Jun, 2010 09:59:45 Top
Andrei Smolin


Add-in Express team


Posts: 17132
Joined: 2006-05-11
Hi Andreas,

Try uninstalling your add-in. Then unregister it from VS. Finally, register it again.

If this doesn't help, please clarify what "does not load" means.

Regards from Belarus (GMT+2),

Andrei Smolin
Add-in Express Team Leader
Posted 28 Jun, 2010 10:13:13 Top
Andreas Lipphardt




Posts: 51
Joined: 2008-12-19
>>Try uninstalling your add-in. Then unregister it from VS. Finally, register it again.
I did exactly what you suggested but this does not help

>>If this doesn't help, please clarify what "does not load" means.
Does not load means that the Add-Inss ribbon is not there and that methods like AddinModule_AddinInitialize are not called anymore.

Besically registering from VS does not work. I have to uninstell and reinstall the setup to make the addin work EACH TIME I REBUILD the addin or make code changes, so that the Add-Ins ribbon is there and that methods like AddinModule_AddinInitialize are called

I have to mention that this all worked fine for many weeks but from one day to the other I stopped working

Andreas
Posted 28 Jun, 2010 11:05:07 Top
Andreas Lipphardt




Posts: 51
Joined: 2008-12-19
We found finally that .NET 4.0 was causing the issue.
Removing .NET 4.0 fixed the issue

Andreas
Posted 28 Jun, 2010 11:47:25 Top
Andrei Smolin


Add-in Express team


Posts: 17132
Joined: 2006-05-11
Hi Andreas,

You need to replace Loader\adxloader.dll in your project with the loader below and re-building your project. Download this file: http://www.add-in-express.com/files/projects_pub/beta2fix/adxloader.zip. Please let me know if this solves the problem.

Regards from Belarus (GMT+2),

Andrei Smolin
Add-in Express Team Leader
Posted 28 Jun, 2010 11:55:15 Top
Andreas Lipphardt




Posts: 51
Joined: 2008-12-19
No. I rebuild my project, un- and re-registered the addin in VS, and the new adxloader seems not to oesnt fix the issue. For some reason the ".NET 4.0 Client framework "stuff is on my cmputer again and I either have to rebuild my setup or I have to uninstall the ".NET 4.0 Client framework "

Andreas
Posted 29 Jun, 2010 02:51:20 Top
Andrei Smolin


Add-in Express team


Posts: 17132
Joined: 2006-05-11
Hi Andreas,

I'm terribly sorry: I've found that you use Add-in Express 2010 and that loader version was intended for Add-in Express 2009. Please forgive me this inatention.

What Add-in Express 2010 build are you using?

Regards from Belarus (GMT+2),

Andrei Smolin
Add-in Express Team Leader
Posted 29 Jun, 2010 03:00:44 Top
Andreas Lipphardt




Posts: 51
Joined: 2008-12-19
I am on v600-b3043-vs-pre.

Andreas
Posted 29 Jun, 2010 05:42:06 Top
Andrei Smolin


Add-in Express team


Posts: 17132
Joined: 2006-05-11
Hi Andreas,

Can you please check that your add-in uses the correct loader version?

Regards from Belarus (GMT+2),

Andrei Smolin
Add-in Express Team Leader
Posted 29 Jun, 2010 05:46:21 Top
Andreas Lipphardt




Posts: 51
Joined: 2008-12-19
I used the loader from the C:\Program Files\Add-in Express\Add-in Express for .NET\Redistributables\ folder

Andreas
Posted 29 Jun, 2010 08:27:53 Top