InstallShield Errors

Add-in Express™ Support Service
That's what is more important than anything else

InstallShield Errors
 
Joseph Major


Guest


Hi.

I have followed some earlier posts regarding how to install an addin using InstallShield. I have got quite far but have encountered a problem and was wondering if anyone else has experienced it. I have used the .NET Installer Class feature with installshield that is almost identical to the custom actions provided in the Visual Studio installer project. I have set the arguments for install, rollback and uninstall to /Addin="[AUDIOWORD]\AudioWord.dll". When I install the project I get the error "Error 1001.InstallUtilLib.dll: Unknown error in CorBindToRuntimeHost (0x80131700). If I manually install the addin using installutil.exe it works fine so I can only assume there is a problem with my InstallShield project. Has anyone used this in the past and had similar problems. I would appreciate any help.

Regards.

Joe Major
Posted 19 Dec, 2005 10:28:00 Top
Sergey Grischenko


Add-in Express team


Posts: 7228
Joined: 2004-07-05
Hi Joe.

I wouldn't advise you to use the InstallUtil tool.
You can use the '.NET Installer Class' and '.NET Installer Class Arguments' properties of the AddinExpress.MSO.dll assembly in the Installshield project.

I will send you an example how to install ADX based add-ins using InstallShield. What version of InstallShield do you use?
Posted 19 Dec, 2005 11:08:47 Top
Joseph Major


Guest


Sergey.

I am using v10.5 and am already using the NET Installer Class and Arguments properties.

It appears that InstallShield uses InstallUtil in the background of the installer class.

An example would be useful.

Thanks once again Sergey.

Regards.

Joe
Posted 19 Dec, 2005 11:31:39 Top
Sergey Grischenko


Add-in Express team


Posts: 7228
Joined: 2004-07-05
Hi Joe.

You can download an example here: http://www.add-in-express.com/projects/myfirstaddin_is.zip
Posted 20 Dec, 2005 10:39:17 Top
Joe Major




Posts: 5
Joined: 2005-12-12
Sergey et all.

I have found a solution to the problem I was getting. I was using a merge module to install the addin and there is a problem with InstallShield not working correctly with installer classes.

InstallShield Knowledge Base

Hope this helps someone in the future.

Regards.

Joe

Posted 05 Jan, 2006 11:16:08 Top
Sergey Grischenko


Add-in Express team


Posts: 7228
Joined: 2004-07-05
Hi Joe.

Thank you for the link.
Posted 06 Jan, 2006 10:10:14 Top