add in load up slowness

Add-in Express™ Support Service
That's what is more important than anything else

add in load up slowness
Word Addin load up takes a long time 
Ken Wong




Posts: 2
Joined: 2010-02-11
I am using Add-In-Express 2009.

I have a Word addin that takes approximately 40 seconds to load in Windows XP SP3, Word 2007.

The issue can be fixed as mentioned here: http://www.add-in-express.com/forum/read.php?FID=5&TID=4408&MID=22287&phrase_id=1742133#message22287

I don't pretend to fully understand the intricacies of the certificate verification process but is there an alternative fix to getting the end user to modify IE security settings? In a small rollout this would be marginally okay but for a big rollout this workaround is not ideal.
Posted 11 Feb, 2010 15:55:41 Top
Andrei Smolin


Add-in Express team


Posts: 15705
Joined: 2006-05-11
Hi Ken,

It seems there's no ideal workaround. At least, we don't know if such a workaround exists. Turning off the antivirus software is definitely not a workaround, but you need to try this way. You can also try disabling all other COM add-ins and Smart tags to find if the delay occurs when your add-in is loaded in a combination with some other Office extension. Finally, try reproducing the issue with a new empty add-in.

As to the certificate verification process, please read what a VSTO guru tells about this when solving (trying to solve) a case of delay at start-up of a VSTO add-in. See VSTO add-in startup problem.

Regards from Belarus (GMT+2),

Andrei Smolin
Add-in Express Team Leader
Posted 12 Feb, 2010 08:10:00 Top
Ken Wong




Posts: 2
Joined: 2010-02-11
Thanx for the link.

In our case, we only see the issue on some of our test machines and it is "fixed" by disabling that verification setting in IE. There are no other addins loaded at the time.

I just hesitate to call this a fix as it seems to make your system "less secure".

--
Ken
Posted 12 Feb, 2010 15:18:21 Top
Andrei Smolin


Add-in Express team


Posts: 15705
Joined: 2006-05-11
Hi Ken,

I would not suggest calling this a fix, too. I've just found the following suggestion on the web:

As an alternative, adding the following line to Hosts file should also resolve the issue :

127.0.0.1 crl.microsoft.com


Please let me know if this helps.

Regards from Belarus (GMT+2),

Andrei Smolin
Add-in Express Team Leader
Posted 15 Feb, 2010 05:02:31 Top