Word 2003 starts very slow

Add-in Express™ Support Service
That's what is more important than anything else

Word 2003 starts very slow
 
Armin Klumpp




Posts: 3
Joined: 2009-10-14
Hi,

What could be the reason for a very slow starup of word 2003 as shown here:
(Addin-Express 2008 .Net, VS2008)

17:47:48 560 Start.
17:47:48 560 Reading the registry key 'HKEY_CLASSES_ROOT\CLSID\{19CFDB40-D959-4931-ACC3-8ACA876C4B1A}'
17:47:48 560 Success. The registry key 'HKEY_CLASSES_ROOT\CLSID\{19CFDB40-D959-4931-ACC3-8ACA876C4B1A}' is closed.
17:47:48 560 Converting the '{4BA250A6-8BCA-46A6-982A-F340081187C3}' CLSID from string.
17:47:48 560 Success.
17:47:48 560 Attempting to get the class object by the '{4BA250A6-8BCA-46A6-982A-F340081187C3}' CLSID.
17:47:48 560 Success.
17:47:48 560 Creating a new instance of the add-in loader.
17:47:48 560 Success.
17:47:48 560 Loading the configuration from the system registry.
17:47:48 560 Getting the lates CLR version.
17:47:48 560 The latest CLR version is 'v2.0.50727'.
17:47:48 560 The configuration has been loaded successfully.
17:47:48 560 Runtime version: v2.0.50727.
17:47:48 560 Assembly name: WordMM, PublicKeyToken=B738D61611050C35.
17:47:48 560 Class name: WordMM.AddinModule.
17:47:48 560 Attempting to create a new instance of the managed add-in class: CLR - v2.0.50727
17:47:48 560 Loading CLR: v2.0.50727.
17:47:48 560 The CLR v2.0.50727 has been initialized successfully.
17:47:48 560 Creating a new domain setup.
17:47:48 560 Success.
17:47:48 560 Getting the add-in directory.
17:47:48 560 Success. The directory is 'C:\src\itl\wordmm\WordMM\bin\Debug\'
17:47:48 560 The configuration file is '(null)'
17:47:48 560 The 'shadow copy' is enabled.
17:47:48 560 Creating a new application domain.
17:47:48 560 Success.
#
# Here the proccess hangs about 30 secs
# =====================================
#
17:48:19 560 Unwrapping the managed class.
17:48:19 560 Success.
17:48:19 560 Querying the add-in extensibility.
17:48:19 560 Querying the custom task panes.
17:48:19 560 Querying the ribbon extensibility.
17:48:19 560 Success.
17:48:19 560 Querying the form regions.
17:48:19 560 Success.
17:48:19 560 The managed add-in class has been created successfully.

Posted 14 Oct, 2009 10:57:42 Top
Sergey Grischenko


Add-in Express team


Posts: 7211
Joined: 2004-07-05
Hi Armin.

Please try to clear the dll cache.
It is located here:

Windows XP:
C:\Documents and Settings\<User>\Local Settings\Application Data\assembly\dl2
C:\Documents and Settings\<User>\Local Settings\Application Data\assembly\dl3

Vista:
C:\Users\<User Name>\AppData\Local\assembly\dl2
C:\Users\<User Name>\AppData\Local\assembly\dl3
Posted 14 Oct, 2009 11:20:20 Top
Armin Klumpp




Posts: 3
Joined: 2009-10-14
Hi Sergey,

thank you for your quick answer.

Please try to clear the dll cache.


I knew this trick, it helped some time ago, but unfortunately not now.

Posted 14 Oct, 2009 11:42:06 Top
Sergey Grischenko


Add-in Express team


Posts: 7211
Joined: 2004-07-05
Armin, do you get the same result with a new empty add-in?
Posted 14 Oct, 2009 11:46:16 Top
Armin Klumpp




Posts: 3
Joined: 2009-10-14
Hi Sergey,


Armin, do you get the same result with a new empty add-in?


I compiled and registered your wtoys example, same result.
Posted 14 Oct, 2009 11:49:16 Top
Sergey Grischenko


Add-in Express team


Posts: 7211
Joined: 2004-07-05
Posted 15 Oct, 2009 05:01:23 Top