WinMail/OE: adxOutlookExpressEvents1_InspectorSend NEVER CALLED

Add-in Express™ Support Service
That's what is more important than anything else

WinMail/OE: adxOutlookExpressEvents1_InspectorSend NEVER CALLED
 
Andrey Yemelyanov




Posts: 70
Joined: 2009-04-21
Hi guys:

For some reason the event handler
adxOutlookExpressEvents1_InspectorSend in the AddinModule is never
called. I checked this by putting smth like
MsgBox("InspectorSend event triggered.") at the very beginning of the method. This message never pops up.

What is interesting is that this behavior is only relevant for adxOutlookExpressEvents1.
Other events like AddinModule_AddinStartupComplete are triggered normally.
Again, I put in a notification MsgBox("AddinStartupComplete event fired") at the beginning of the method and it pops up every time I start WinMail.

Now the one million dollar question is why this happens... I have
a suspicion that this could be due to the fact that during the installation
we register with regsvr32.exe(some custom WiX code):

<CustomAction Id="RegisterOeapiinitcom"
Directory="OEAPI"
ExeCommand='regsvr32.exe /s "oeapiinitcom.dll"'
Return="check"/>

<CustomAction Id="RegisterOecom"
Directory="OEAPI"
ExeCommand='regsvr32.exe /s "oecom.dll"'
Return="check"/>
<CustomAction Id="RegisterOestore"
Directory="OEAPI"
ExeCommand='regsvr32.exe /s "oestore.dll"'
Return="check"/>

According to Nektra deployment guidelines we must always register
these dlls.

Still if you remove /s attribute (silent registration) from each registration you will see that all of them are registered normally.

Maybe somehow this messes up the event manager. I do not know. But I did
try to ignore them and registered only adxoeloader.dll. The installation went well but then WinMail crashed on startup. It looks like the only time our addin does not crash is when you indeed register the components mentioned above. Then WinMail starts normally, our addin is successfully loaded. The addin express log file does not list any errors. You can even access MyAccount, HelpForm and other custom forms. So these events work as they are supposed to. But adxOutlookExpressEvents1 events never get triggered.

Could you please point me to what I might be doing wrong, or
what I should pay attention to.

Regards,
Andrey.
Posted 23 Sep, 2009 23:38:27 Top
Fedor Shihantsov


Add-in Express team


Posts: 1188
Joined: 2005-01-11
Hello Andrey,

I have just successfully tested the InspectorSend event in my Vista 32 / WinMail.

What capacity? version? of WinMail do you use (32-bit or 64-bit)?
Please note that the current version of Add-in Express does not support WinMail 64-bit.
Is this issue reproducible on your developer's PC?
Posted 25 Sep, 2009 06:51:07 Top
Andrey Yemelyanov




Posts: 70
Joined: 2009-04-21
Hi Fedor:

Thanks for your reply. Fortunately, we have been able
to resolve this issue on our own. It appears that the
addin express for OE relies on Nektra OEAPI files:
oehook, oestore, oecom, launcher and oeapiinitcom versioned
as 3.2.2. We, however, overrode these defaults with version
3.2.3 downloaded from Nektra's website. This is when InspectorSend
event stopped working. But now we have reverted back to 3.2.2.
located in Redistributables folder of our addin express installation.
Now everything works!

/Andrey
Posted 25 Sep, 2009 07:38:30 Top
Andrei Smolin


Add-in Express team


Posts: 17360
Joined: 2006-05-11
Hello Andrey,

Many thanks for letting us know!

Regards from Belarus (GMT+2),

Andrei Smolin
Add-in Express Team Leader
Posted 25 Sep, 2009 07:55:39 Top