Windows 2008 ADX Loader error

Add-in Express™ Support Service
That's what is more important than anything else

Windows 2008 ADX Loader error
Problem with Instaling Plugin in Windows Server 2008 
David Thomson




Posts: 12
Joined: 2006-10-23
I am testing a Outlook plug-in for Windows Server 2008. I made a Installer and then tried to load it. Everything goes fine and then all of a sudden it crashes and rolls the install back. I looked at the Install log file and I see this.

16:15:43 980 Calling the managed procedure to register the 'MyPlugin', PublicKeyToken=93377afdfa78e749' assembly.
16:15:43 980 Error: Not enough storage is available to complete this operation.


I have plenty of storage and I increased my RAM when this happened but it still does this.

Does AddinExpress support Server 2008?

Posted 24 Jul, 2008 20:39:12 Top
Andrei Smolin


Add-in Express team


Posts: 16980
Joined: 2006-05-11
David,

What Add-in Express version do you use?

Regards from Belarus (GMT+2),

Andrei Smolin
Add-in Express Team Leader
Posted 25 Jul, 2008 07:14:01 Top
David Thomson




Posts: 12
Joined: 2006-10-23
I am using Add-in Express 2008
Posted 25 Jul, 2008 13:51:35 Top
Eugene Astafiev


Add-in Express team


Posts: 8540
Joined: 2007-07-25
Hello David,

Please remove all custom code from the add-in constructor. If it doesn't help, please send us the add-in project to the support e-mail address (see readme.txt).
.NET, Extended MAPI, Windows Phone & RT
Posted 28 Jul, 2008 11:54:43 Top
David Thomson




Posts: 12
Joined: 2006-10-23
Hi Eugene, I have no custom code in my Constructor. I have tried creating a generic project with a simple ribbon tab and a command bar button and this failed to setup with the same error message.
Posted 28 Jul, 2008 15:07:46 Top
Eugene Astafiev


Add-in Express team


Posts: 8540
Joined: 2007-07-25
Hi David,

1. Is the UAC enabled?
2. Do you run setup.exe?
.NET, Extended MAPI, Windows Phone & RT
Posted 28 Jul, 2008 16:04:10 Top
David Thomson




Posts: 12
Joined: 2006-10-23
I have disabled UAC as a test and this still happened. I have run the Setup.exe and the the ProjectName.exe and this is still happening.
Posted 28 Jul, 2008 16:56:27 Top
Eugene Astafiev


Add-in Express team


Posts: 8540
Joined: 2007-07-25
Hi David,

I have tested your issue. A sample add-in is installed successfully. I run Outlook and see my add-in working.

Please supply us with the following info:

1. Outlook version and build number with SP
2. OS platform (x86 or x64)

Could you send us your sample project to the support e-mail address? You can find the support e-mail address in the readme.txt.
.NET, Extended MAPI, Windows Phone & RT
Posted 29 Jul, 2008 08:25:54 Top
David Thomson




Posts: 12
Joined: 2006-10-23
Will do.

Thanks
Posted 31 Jul, 2008 14:27:39 Top
Eugene Astafiev


Add-in Express team


Posts: 8540
Joined: 2007-07-25
Hi David,

You didn't supply me with points of interest listed below.

I have tested your sample project and don't get anything strange. The add-in works fine on Windows Server 2008.

Do you use only one virtual PC image with Windows Server 2008 for testing?
.NET, Extended MAPI, Windows Phone & RT
Posted 01 Aug, 2008 15:32:03 Top