Vista and Protected Mode

Add-in Express™ Support Service
That's what is more important than anything else

Vista and Protected Mode
 
Carl Durocher




Posts: 16
Joined: 2008-05-22
We developped an Internet Explorer Sidebar using your Add-In Express for IE and we have an issue while using an external library (in this exemple WSE 3.0 Microsoft WSE 3.0). While openning the sidebar we are calling a web-service using few WSE 3.0 classes and methods. Everything is working fine with Windows XP, IE 6.0 and 7.0. But while using Vista and IE 7.0 we got an error message and this happens only with the sidebar (we are doing the same with a standard .Net application under Vista and it works). If the current web-page (wihtin IE) is trusted (you can see the "protected mode on" in the IE status bar), everything is working perfectly; but when we open a non trusted page (google for instance) the "protected mode" is set to "off" (You can see it in the status bar of IE) and then we got an exception message while opening our sidebar when we try to use this library :
Could not find a part of the path 'C:\Users\cdurocher\AppData\Local\Microsoft\Windows\Temporary Internet Files\Virtualized\C\Users\cdurocher\AppData\Local\Temp\Low\pl40ohxg.tmp'.


Do you have any idea about it? A way to fix that or maybe something to do with the security level of the addin?

Thanks

Carl
Posted 19 Jun, 2008 15:22:10 Top
Sergey Grischenko


Add-in Express team


Posts: 7229
Joined: 2004-07-05
Hi Carl.

Do you know what the code produces the error? Did you try to debug the add-on?
Posted 20 Jun, 2008 10:04:20 Top
Carl Durocher




Posts: 16
Joined: 2008-05-22
The error is the part Quoted in my first message. It's an InvalidDirectoryException exception.

I checked out a couple web sites and found this one explaining the Protected Mode.

Now when I go in the IE Addons list I see my plugin with this GUID associated with it : {B9DB513B-4FED-4560-8572-BEA47AAA2258} Points to adxloader.dll. So I suppose the adxloader.dll loads the addin so I follow the steps in the Protected Mode explanation website. I tried to add these keys to the "SOFTWARE\Microsoft\Internet Explorer\Low Rights\ElevationPolicy" registry key but with no success so far.

I tried something like that :

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Low Rights\ElevationPolicy\{B9DB513B-4FED-4560-8572-BEA47AAA2258}]
"Policy"=dword:00000003
"CLSID"="{740ED9BF-ABD8-3F0D-BBB6-13FADE47E38D}"


{740ED9BF-ABD8-3F0D-BBB6-13FADE47E38D} is the GUID of the installation MSI.

Well that's what I got so far.

Thanks again Sergey!

Carl
Posted 20 Jun, 2008 10:56:07 Top
Sergey Grischenko


Add-in Express team


Posts: 7229
Joined: 2004-07-05
As far as I understand, you get the error when the Protected Mode is turned off. Am I right?
Do you get this error with a new empty explorer bar?
Posted 20 Jun, 2008 11:02:55 Top
Carl Durocher




Posts: 16
Joined: 2008-05-22
No when the Protected Mode is On, then I get the error.

First time I open a window with a trusted site, everything works fine since Protected Mode is Off. Meaning the process is running in Medium Right Level. Then I try a site not trusted by default (google is not). So I close the browser and open a new one with google in the address bar. Then I open my sidebar (In View->Explorer Bar->My Bar). The sidebar loads then I get the error since it consider the Zone im into to put me in Protected Mode or not.

And no I don't get the error with a an empty explorer bar since it don't call the web service. I'm wondering if you can help us on how to actually elevate the executing right from Low to Medium in IE execution process?

Thanks!

Carl
Posted 20 Jun, 2008 11:29:32 Top
Sergey Grischenko


Add-in Express team


Posts: 7229
Joined: 2004-07-05
Ok, I was just confused with the following text:
but when we open a non trusted page (google for instance) the "protected mode" is set to "off" (You can see it in the status bar of IE) and then we got an exception message while opening our sidebar when we try to use this library :


The fact is that when the Protected Mode is On, IE add-ons should implement the Protected Mode API to access the file system as well as system registry. Please read the following article:
http://msdn2.microsoft.com/en-us/library/ms537312(VS.85).aspx
Posted 20 Jun, 2008 12:19:45 Top