Using Security Manager 2007 with Vista and UAC

Add-in Express™ Support Service
That's what is more important than anything else

Using Security Manager 2007 with Vista and UAC
 
Stephen Moore




Posts: 2
Joined: 2008-03-20
This does not appear to be a problem with Add-in Express, but I was wondering if some-one would be able to answer a query.

I have written a little C# application which is using Security Manager 2007. It was written and tested using XP and Outlook 2003, but some of my users have it working under Vista and Office 2007 whilst others are having problems. I have since discovered that if a user runs OutLook as an administrator and then runs my program, it will work, but if they start OutLook in normal mode, then my program crashes before on the last line of the same code below

private Type comType;
public object comObject;

comType = Type.GetTypeFromProgID("Outlook.Application");
comObject = Activator.CreateInstance(comType);

So, I was wondering if any knows whether this method should still work in non Administrator mode.

Thanks in advance

Stephen
Posted 20 Mar, 2008 19:47:55 Top
Sergey Grischenko


Add-in Express team


Posts: 7230
Joined: 2004-07-05
Hi Stephen.

I tested the SendMail example from the Add-in Express installation package under the admin and non-admin user's account in Vista. It worked fine with UAC turned on. Please test the example on the problematic PC.
Posted 21 Mar, 2008 10:37:28 Top
Stephen Moore




Posts: 2
Joined: 2008-03-20
Thanks Sergey

It initially didn't work, but after rebooting his machine it worked.

I have finally figured out why. The first time he tried it he had previously started outlook as Administrator mode (so that my program would work) and then when he rebooted, he started outlook in normal mode.

It would appear that both Outlook and the calling program (whether your sendmail example or my program) have to be running in the same mode.

Ie

If you run Outlook and sendmail both as administrator then it works.
If you run Outlook and sendmail both in normal mode then it works.
If you run OutLook as Administrator and sendmail normally it will not work
If you run Outlook normally and Sendmail as administrator it will not work.

As yes, he was (for some reason) running my program as administrator. He switched it back to running in normal mode and now everything is working.

Thanks again for your help
Posted 21 Mar, 2008 15:01:58 Top