XLL add-in deployment issue

Add-in Express™ Support Service
That's what is more important than anything else

XLL add-in deployment issue
XLL add-in is not registered on the target machine 
Cristian Corutiu




Posts: 13
Joined: 2007-09-26
Hi,

I have created an xll add-in from scratch using the wizard in vs.net 2005 and uncommented the sample functions in the xll module.
Everything works fine in debug mode but when I deploy the add-in to a clean machine for tests (Win XP SP2 + Excel 2002) the add-in is not listed in the Add-in manager as expected. However it becomes available (listed and checked in the Excel add-in manager) if I register the adxloader running regsvr32 utility manually.
I used the setup automatically created by the wizard.

Can you please help me with this issue?

Thanks,
Cristi
Posted 12 Nov, 2007 11:04:39 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Cristi.

Please check if the custom actions are present in the Custom Actions editor of the setup project. Did you change the name or the strong name of the add-in assembly?
Posted 12 Nov, 2007 12:23:37 Top
Cristian Corutiu




Posts: 13
Joined: 2007-09-26
Hi Sergey,

The Custom Actions are there (DllRegister and DllUnregister entry points).I have not changed the strong name.
What I have just notice is that I uninstall and then reinstall the addin ( keeping the .net framework 2.0 and the other two prerequisites ) , the addin is correctly registered.
Another Issue I have noticed is that the second installation does not detect that the KB809002 is already installed and installs it again.

Thanks for help,
Cristi
Posted 12 Nov, 2007 12:37:43 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
It is normal.
Posted 12 Nov, 2007 12:42:41 Top
Cristian Corutiu




Posts: 13
Joined: 2007-09-26
So , is there anything I can do to correctly install and register the XLL add-in on a clean machine using the generated setup (.net framework 2.0 + the other two prerequisites included ) ?

Thanks,
Cristi
Posted 12 Nov, 2007 16:27:09 Top
Cristian Corutiu




Posts: 13
Joined: 2007-09-26
One more think I have noticed.If I run a repair after installation the addin becomes registered.
Maybe this helps.
Any ideea ?

Thank you,
Cristi
Posted 13 Nov, 2007 04:36:23 Top
Cristian Corutiu




Posts: 13
Joined: 2007-09-26
Hi Sergey,

I found the problem: I used for testing a virtual machine with Excel installed.The problem described above occurs if Excel is not opened at least once before installing the add-in because a key needed by the addin installation is created only at the MS Excel first run.

Thank you anyway,
Cristi
Posted 13 Nov, 2007 08:04:47 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Cristi.

Ok. Please let me know if you face any other difficulties.
Posted 13 Nov, 2007 09:55:47 Top