ActiveX component create object

Add-in Express™ Support Service
That's what is more important than anything else

ActiveX component create object
 
Joost Verdaasdonk




Posts: 39
Joined: 2007-05-25
Hi,

I'm having a problem with one of my installers.
The problem is that the primary output for the WordAddin is no longer recognized by the setup project.

To resolve this I readded the primary output and now all looks fine. (visually)

So I've build a MSI from the project and installed. it.

When I start Word my Com addin doesn't get loaded automatically so I looked in the registry if the loadbehaviour was correct. (btw registerallusers is set to true in addin)

The registry was fine so I tried to load the addin by hand with VBA setting the .Connect property of the addin to True.

When I do that I get the following error:
Run-time error '429'
ActiveX component create object

Basicly this tels me something is a miss in my setup sollution but I don't have a clue where to look for the sollution.

The version of AddinExpress.mso = 2.8.1763.2003
And adxloader = 1.0.0.1

Does anyone have an idea for a possible sollution.

Thank you
Regards,
ManualMaster Development
Posted 13 Jun, 2007 11:58:40 Top
Sergey Grischenko


Add-in Express team


Posts: 7224
Joined: 2004-07-05
Hi Joost.

Please send me the project. I will check it.


P.S. Note that we take up your forum requests in the order we receive them.
Besides, it may take us some time to investigate your issue. Please be sure we will let you know as soon as the best possible solution is found.
Posted 14 Jun, 2007 10:19:58 Top
Joost Verdaasdonk




Posts: 39
Joined: 2007-05-25
Hi Sergey,

Thank you for your offer but that won't work.

My project includes 20 other projects with a lot of dependicies. And I have no smaller project that has the same problem.

If I'd send you the MSI would that help?

And if not do you have any ideas on possible reasons for this type of error.

Your effort is much appreciated.
Regards,
ManualMaster Development
Posted 16 Jun, 2007 17:40:13 Top
Sergey Grischenko


Add-in Express team


Posts: 7224
Joined: 2004-07-05
Hi Joost.

Could you please create a simple add-in and register it? Do you get the same issue?

Posted 18 Jun, 2007 16:09:28 Top
Joost Verdaasdonk




Posts: 39
Joined: 2007-05-25
Hi Sergey,

Thanks for your answer.

Nope all newly build add-ins work just fine.
This add-in was retrieved from source safe and it had a reference to a previous version (2.6) of add-in mso.

I've checked if all references are properly updated to the 2.8 version and that the loader manifest and dll versions where all correct. I couldn't find any problems. (perhaps the problem lies here...)

I'm sure I'm missing something simple here but I haven't got a clue...
Regards,
ManualMaster Development
Posted 18 Jun, 2007 17:53:57 Top
Joost Verdaasdonk




Posts: 39
Joined: 2007-05-25
Hi Sergey,

I'm checking all my dependencies now using several tools.
On of them is Dependency walker.

If you open the ADXLOADER.dll I get the following error:
Error: The Side-by-Side configuration information in "d:\projects\mspattex\mmwordaddin\loader\ADXLOADER.DLL.manifest" contains errors. This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem (14001).

The contents of the manifest is:
<?xml version="1.0" encoding="utf-8"?>
<configuration>
<assemblyIdentity name="MMWordAddin, PublicKeyToken=3837c808476bdea6" />
</configuration>

The information seems to be valid.

Any thoughts?
Thank you
Regards,
ManualMaster Development
Posted 19 Jun, 2007 06:12:47 Top
Sergey Grischenko


Add-in Express team


Posts: 7224
Joined: 2004-07-05
Hi Joost.

Did you add any code to the add-in constructor?
Posted 19 Jun, 2007 09:28:39 Top
Joost Verdaasdonk




Posts: 39
Joined: 2007-05-25
Hi Sergey,

We've added some basic log statements to the code like:

#Region " Constructors & destructors "
    Public Sub New()
        MyBase.New()
        mmDebug.WriteLine("AddinModuleConstructor: Start")            'MLHIDE
        'This call is required by the Component Designer
        Try
            InitializeComponent()
        Catch ex As Exception
            MsgBox(ml_string(2, "error: ") + ex.Message + ml_string(1, " Problem initializing component."), MsgBoxStyle.Critical, "Word add-in") 'MLHIDE
        End Try

        'Add any initialization after the InitializeComponent() call
        mmDebug.WriteLine("AddinModuleConstructor: Completed")        'MLHIDE
    End Sub
#End Region


But on a separate note I had a bit of a break-through today in the setup project. All is compiling now and the setup is installing the add-in correct. (error is gone)

The problem was that the primary output of the add-in project was set to vsdrpCOM after I changed it to: vsdrpDoNotRegister all was wel. :)

I still wonder about the error Dependency walker is giving me examening the adxloader.dll.

Any thoughts on that one?
Thanks
Regards,
ManualMaster Development
Posted 19 Jun, 2007 13:05:19 Top
Sergey Grischenko


Add-in Express team


Posts: 7224
Joined: 2004-07-05
Hi Joost.

The fact is that the adxloader.dll is an unmanaged dll written in C++. So the Dependency walker will not work correctly examining it.
Posted 20 Jun, 2007 08:04:41 Top
Joost Verdaasdonk




Posts: 39
Joined: 2007-05-25
Hi Sergey,

Ah ok so nothing to worrie about.
Ok than all is resolved now.

Thanks for your efforts.
Regards,
ManualMaster Development
Posted 20 Jun, 2007 09:29:15 Top