Signed addin does not load in Outlook

Add-in Express™ Support Service
That's what is more important than anything else

Signed addin does not load in Outlook
 
Mark Donne




Posts: 5
Joined: 2016-01-06
Hi Forum

We have an unusual problem with an Addin we have developed for Outlook using Add-in Express and I am not sure where to start looking.

We recently had to update our Code Signing Certificate from Sectigo and at the same time we updated Addin express to the latest version 9.5.4661.0

We can sign the application using "Add-in Express -> Signing Options" and the project builds fine with no errors and the files are all correctly signed. We can verify this by looking at the files and seeing the Digital signature is there and the certificate is valid however the addin does not appear in Outlook at all.

It all appears to load ok as we can see the addin is loaded by viewing the COM addins and we can also see this in the Event Viewer but it does not appear on the Ribbon.

If we build the same project with Signing Options disabled it all works fine and the addin appears as normal.

So, we know it is the signing options causing this but what could be the cause? There are no errors in Outlook and I can't for the life of me think where to start looking to see why the addin is not showing.

We have tried setting the 2 Environment variable for Outlook VTSO but they didn't appear to show anything.

Any help or pointers on diagnosing why a signed Addin wont show in Outlook, it does load it just doesn't show, would be most welcome!

Thanks
Mark Donne
Posted 11 Nov, 2021 13:00:01 Top
Andrei Smolin


Add-in Express team


Posts: 18506
Joined: 2006-05-11
Hello Mark,

Could you please reproduce the issue and send me the adxloader.log describing how your add-in was loaded in that session? Find the support email address in {Add-in Express installation folder}\readme.txt; please make sure your email contains a link to this topic.

Regards from Poland (CEST),

Andrei Smolin
Add-in Express Team Leader
Posted 15 Nov, 2021 03:18:30 Top
Mark Donne




Posts: 5
Joined: 2016-01-06
Hi Andrei

Thank you for your response but we have managed to fix/work around this now.

We ended up rolling our code back to an earlier release and the newly signed addin started working again even after it was signed.

I have no idea why it went wrong but I am just glad that we got it working.

Regards
Mark Donne
Posted 15 Nov, 2021 11:00:47 Top
Andrei Smolin


Add-in Express team


Posts: 18506
Joined: 2006-05-11
That is: No problem!

Regards from Poland (CEST),

Andrei Smolin
Add-in Express Team Leader
Posted 17 Nov, 2021 03:28:11 Top