Insallation Problem

Add-in Express™ Support Service
That's what is more important than anything else

Insallation Problem
AddIn is not shown in Excel 
Michael Kaden




Posts: 255
Joined: 2017-11-15
Hello Andrei,

just send an email to support.

kind regards & thank you

Michael
Posted 11 Oct, 2019 04:35:59 Top
Andrei Smolin


Add-in Express team


Posts: 17375
Joined: 2006-05-11
Hello Michael,

The adxregistrator.log is okay. I suggest that reinstall the add-in and check if starting Excel for the first time after that creates or updates adxloader.log in {user profile}\AppData\Local\Temp\<ProductName>\adxloader.log; the ProductName part reflects the ProductName field of AssemblyInfo.cs (AssemblyInfo.vb). If the file is created/updated, send it to me. Otherwise, check all of the options listed in section Troubleshooting add-in loading; see the PDF file in the folder {Add-in Express}\Docs on your development PC.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 11 Oct, 2019 06:09:44 Top
Michael Kaden




Posts: 255
Joined: 2017-11-15
Dear Andrei,

Thank you very much for the prompt reply.

There is no adxloader.log
The configuration in my adxloader.dll.manifest =

<loaderSettings generateLogFile="true" shadowCopyEnabled="false" privileges="user" minOfficeVersionSupported="14" />

Thank you & kind regards
Michael
Posted 11 Oct, 2019 06:40:42 Top
Andrei Smolin


Add-in Express team


Posts: 17375
Joined: 2006-05-11
Michael,

Check that section in the manual.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 11 Oct, 2019 06:48:47 Top
Michael Kaden




Posts: 255
Joined: 2017-11-15
Dear Andrei,

I looked at all, as far as I can understand:

Add-in is not registered
As the adxregistrator.log has no problems, I assume this is not the problem?

Per-User Add-in is registered for System User As there is no adxloader.log, I assume this is not the problem?

Add-in is Inactive
The Add-ins (both ComAddIn & Excel AddIn) is not listed in the AddIn, also not in the Inactive or Disabled AddIn's, so I assume this is not the problem?

Add-in is Disabled
The Add-ins (both ComAddIn & Excel AddIn) is not listed in the AddIn, also not in the Inactive or Disabled AddIn's, so I assume this is not the problem?

Digital Signature is Missing or Invalid Our Project is digitally signed with a valid code signing certificates, there are also no (unsafe) warnings coming up during the installation as it would be expected if the code signing certificate would be invalid.

Administrator cannot Load Per-user Add-in
We tried Installation as User & as Administrator, so I assume this is not the problem?

Per-machine Add-in Loads only for Administrator We have a per-user AddIn is this chapter also applicable?
We will search for alera.exe outside of [ProgramFilesFolder].
We tried Installation as User & as Administrator, so I assume this is not the problem?
Do I understand that it could be installed for administrator, so if the client runs Excel as administrator, then it would run?
But how do you run Excel as administrator?

All Application Add-ins are Disabled by User
The client has installed other Excel AddIns with no problem, we tried Installation as User & as Administrator, so I assume this is not the problem?

All Application Add-ins are Disabled by Administrator
The client has installed other Excel AddIns with no problem,

XLL add-in is blocked
Both COM and XXL are not loaded, but I will check the trust centre with the client
Posted 11 Oct, 2019 07:41:43 Top
Michael Kaden




Posts: 255
Joined: 2017-11-15
the modify does not work

I wanted to add

Thank you & kind regards

Michal
Posted 11 Oct, 2019 07:43:22 Top
Andrei Smolin


Add-in Express team


Posts: 17375
Joined: 2006-05-11
Hello Michael,

Michael Kaden writes:
We tried Installation as User & as Administrator, so I assume this is not the problem?


This is different. If an administrator user installs a per-user add-in (whether using standard permissions or admin permissions to run the installer) and then starts the host application *elevated*, the add-in won't load. This is by Windows design. Start Excel.exe right from {Program files}\Microsoft Office\root\Office16\ to check if the add-in loads in this case. Also, in the Task Manager window check if EXCEL.EXE is started for the user who logs in Windows; once we saw how Excel started from the Start menu was actually started fro some other user.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 11 Oct, 2019 07:57:51 Top
Michael Kaden




Posts: 255
Joined: 2017-11-15
Dear Andrei,

thank you for your response.

I do not know what you mean with "starting the host application *elevated*"?

Can you run Windows without being logged on as a user?

Whenever I start Excel while I am a user, Excel shows to run in the user I am in. I cannot start Windows without choosing a user. So Excel will always use the AddIn installed for that user?

If I go to the task manager, the user tap always shows the user I am logged on. Can you have more than one user in the task Manager user tap?

Am I missing something easy here?

When I install the AddIn the installer has a default location:

C:\Users\Alera 02\AppData\Local\alera\alera Thermal\

Or "Alera 03" if that is my current user.

Where in my project setup would I change this default location? I could not find it.

If I change it manually, for example to C:\Program Files\alera or C:\Program Files (x86)\alera no problem if I only have 1 user.

If I have 2 users, all hell brakes loose. De-installing it on one user lets not de-install or re-install it on the other user etc. I cannot get ride of the icon in Programs and features etc. So I assume that it has to be installed in the User AppData.

Sorry for being so useless, please help me to understand

Thanks again & kind regards

Michael
Posted 11 Oct, 2019 12:42:10 Top
Andrei Smolin


Add-in Express team


Posts: 17375
Joined: 2006-05-11
Hello Michael,

With UAC enabled, an administrator can only use administrative privileges from an elevated application. An application is elevated if you start it via the "Run as administrator" option. When you start Excel, you are using a shortcut that may elevate Excel for you. Starting EXCEL.EXE right from the Office folder lets you bypass using that shortcut.

Michael Kaden writes:
the user tap always shows the user I am logged on.


This is what we are used to see. This doesn't mean however that this may not work differently. I saw this myself: the user starts Excel and the Task Manager shows that EXCEL.EXE is run for another user. I don't know how to achieve this.

Andrei Smolin writes:
We tried Installation as User & as Administrator


A per-user add-in installs for the user starting the installer. The add-in loads for the user starting Excel *if* it is registered for that user. There are issues that relates to having registered the add-in for one user while the user starting Excel is different.

Per-user and per-machine add-ins have different requirements; these are listed in sections:
- Deploying a per-user Office extension via an MSI installer
- Deploying a per-machine Office extension via an MSI installer

There's a case when there's no difference if the installer is elevated or not: if you install a per-user add-in for an admin user. Per-machine add-ins must be installed by admins and the installer must be run elevated.

There's a difference if EXCEL itself is elevated. If an admin user starts Excel elevated and UAC is on (note that UAC is on by default), no per-user add-in will load. This is how Windows handles COM objects in this case.

Michael Kaden writes:
If I change it manually, for example to C:\Program Files\alera or C:\Program Files (x86)\alera no problem if I only have 1 user.


Since writing to Program Files requires administrative permission, this can be done only if the installer is run by an administrator. Because you don't create an add-in for admin users only, installing an add-in in this location only make sense if the add-in is per machine.

Michael Kaden writes:
De-installing it on one user lets not de-install or re-install it on the other user etc. I cannot get ride of the icon in Programs and features etc.


I suppose this occurs if you install a per-user add-in in the same location outside of the user's profile.

Before you continue, uninstall the add-in. Then, if it is a per-user add-in, install it in the user's profile for each of the users involved and then uninstall it. This sequence should unregister that add-in for each used. Check this: start Excel to make sure that the add-in is missing in the Excel UI.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 14 Oct, 2019 01:47:16 Top
Michael Kaden




Posts: 255
Joined: 2017-11-15
Dear Andrei,

thank you very much for your reply.

I went through

- Deploying a per-user Office extension via an MSI installer

- Deploying a per-machine Office extension via an MSI installer

Step by step again.

The project is a per-user installation:

Set RegisterForAllUsers = false - Is correctly set.

The Platform target property is set to Any CPU

The DefaultLocation property is set to [AppDataFolder][Manufacturer]\[ProductName]

Custom actions are set to

Install:
adxregistrator.exe
/install="alera.dll" /privileges=user

Rollback:
adxregistrator.exe
/uninstall="alera.dll" /privileges=user /generateLogFile=false

Uninstall:
adxregistrator.exe
/uninstall="alera.dll" /privileges=user

PostBuildEvent is set to
"C:\Program Files (x86)\Add-in Express\Add-in Express for .NET\Bin\adxpatch.exe" "$(BuiltOuputPath)" /UAC=Off /RunActionsAsInvoker=true

I do not use any prerequisites

The client has multiple users on his machine, but only uses EXCEL with one specific user. This user is called "Hagen Sagasser". If you look at the adxregistrator.log, you can see that this user is also used for the installation. It also says:

Process Owner: Administrator
Run 'As Administrator': No
Process Elevated: No
Integrity Level: Medium
UAC (User Account Control): On

strange as UAC is set to OFF in my PostBuildEvent

The installation goes through without any error, however:

The AddIns (COM & Excel) do not show in Excel-Options-AddIn ComAddIns / ExcelAddIns / Disabled Items
The alera Program does not show in Programs & Features in the Control Panel

So there is nothing what the client can de-install.

Strangely enough they have a second computer with exactly the same set up (in another location) and the installation works without problem.

Any idea where we could look next?

Thank you and kind regards

Michael






The installation goes through without error, however:
Posted 14 Oct, 2019 07:36:53 Top