Cannot install AE Outlook Add-In using ClickOnce

Add-in Express™ Support Service
That's what is more important than anything else

Cannot install AE Outlook Add-In using ClickOnce
Cannot install AE Outlook Add-In using ClickOnce 
Subscribe
SimonKravis




Posts: 17
Joined: 2013-11-25
I am trying to build an Outlook Add-In (OutlookTag) using C# in VS 2013 with Add-InExpress from which I want to call a Windows Forms application (SetTags.exe). I have created a new Add-In Express class library project within the same solution and can create and build the Add-In, which contains reference to the SetTags project. I can also publish the project, but when I try to install it by clicking OutlookTag.Application in the publish folder I get the error "Reference in the manifest does not match the identity of the downloaded assembly SetTags.exe"

This seems to be a common problem - I have tried the solutions suggested in

https://stackoverflow.com/questions/5337458/error-deploying-clickonce-application-reference-in-the-manifest-does-not-match

I have found the following:

1) If I set the ClickOnce security setting in SetTags project to Full or partial Trust I get the message "ClickOnce does not support the request execution level 'requireAdministrator'"
2) I cannot set the Manifest setting in Application->Icon and Manifest Settings to "Create Application without a Manifest" because the project is a class library, and the options are greyed out with "Embed manifest with default settings" fixed.
3) Neither changing the Configuration from Debug to Release for both projects or changing the platform of both projects to 32 bit fixed the problem
Posted 16 Jun, 2019 22:08:49 Top
Andrei Smolin


Add-in Express team


Posts: 16459
Joined: 2006-05-11
Hello Simon,

You need to use the Add-in Express Publish wizard. See section Add-in Express ClickOnce Solution, see the PDF file in the folder {Add-in Express}\Docs on your development PC.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 17 Jun, 2019 09:40:25 Top
SimonKravis




Posts: 17
Joined: 2013-11-25
I am following the procedure defined on pages 282-289 of adxnet, in folder C:\Program Files (x86)\Add-in Express\Add-in Express for .NET\Docs.

I get the same error message if I select Publish from the Add-In Express menu option visible in the context menu shown by right-clicking the OutlookTag project and then try and install the Add-In by clicking on OutlookTag.application
Posted 17 Jun, 2019 23:35:13 Top
Sergey Grischenko


Add-in Express team


Posts: 7229
Joined: 2004-07-05
Hi Simon,

Can you please send a sample solution with this issue on the support e-mail? I will check it.
Posted 18 Jun, 2019 04:01:40 Top
SimonKravis




Posts: 17
Joined: 2013-11-25
I use so many external dlls (some commercial) in SetTags.exe that I don't think I would be able to send you a buildable version of the solution. I will try and reproduce the problem with a different .exe without any external components and send you that.
Posted 19 Jun, 2019 00:38:23 Top
Andrei Smolin


Add-in Express team


Posts: 16459
Joined: 2006-05-11
Okay, thanks.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 19 Jun, 2019 06:54:27 Top
SimonKravis




Posts: 17
Joined: 2013-11-25
If I remove all references to all other projects in the solution while OutlookTags was one of many subprojects, I received the message "Reference in the manifest does not match the downloaded assembly Outlooktag.exe". However, I have been able to create and Publish an Outlook Add-In OutlookTag in a separate solution and calling SetTags as an executable.

I have noticed the following two problems which you might like to mention in the help documentation or rectify in future releases.

1) Copying and pasting an ADXRibbonTab control results in a second control with the same ID as the first. This causes problems if the two tab controls are to be shown on different ribbons. Multiple tab controls should be created from scratch.

2) The Ribbons parameters "Outlook MailRead" and "OutlookMailCompose" are transposed.
Posted 19 Jun, 2019 23:02:59 Top
Andrei Smolin


Add-in Express team


Posts: 16459
Joined: 2006-05-11
Hello Simon,

Thank you for letting us know and for the suggestions!

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 20 Jun, 2019 00:52:30 Top
SimonKravis




Posts: 17
Joined: 2013-11-25
In trying to prepare a single solution showing the problem I found that it disappeared: if the Add-In is the only project in the solution it publishes and installs OK. So I think the problem is something to do with other projects in the solution.
Posted 03 Jul, 2019 02:39:28 Top
Andrei Smolin


Add-in Express team


Posts: 16459
Joined: 2006-05-11
Hello Simon,

Do you have an unloaded project in the solution?

What Add-in Express build are you using?

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 03 Jul, 2019 05:40:15 Top