Question regarding downloader for AddIn.

Add-in Express™ Support Service
That's what is more important than anything else

Question regarding downloader for AddIn.
Can the downloader.exe load always the latestet version found in version_info.xml file 
Subscribe
Dirk




Posts: 73
Joined: 2017-10-05
Hello,

We have a problem with the downloader of our excel addin. The download loads the msi and starts the setup of our addin. If a specific version is not found in the version_info.xml, because we already updated to a newer version on our donwload area, the downloader shows an error. Is it possible that the downloader always loads the latest version found in version_info.xml? in our case we only have exactly one version in the version_info.xml and no former version.

Best regards
Dirk
Posted 20 Mar, 2019 05:43:46 Top
Andrei Smolin


Add-in Express team


Posts: 16313
Joined: 2006-05-11
Hello Dirk,

Before you start a downloader, you should check if there is anew version; use CheckForMSIUpdates() to do this. If there's no new version, you can show a message to the user.

Dirk Reuß writes:
Is it possible that the downloader always loads the latest version found in version_info.xml?


No. Every downloader is built for a specific add-in version; it can only download that add-in version.

Dirk Reuß writes:
in our case we only have exactly one version in the version_info.xml and no former version.


We recommend that you keep all versions in version_info. Otherwise, ClickTwice may fail and the old add-in version may not uninstall.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 22 Mar, 2019 07:08:09 Top
Dirk




Posts: 73
Joined: 2017-10-05
From a build process perspective it is not good practice to have a version_info.xml as state for many versions.
Each build should be able to create it's one independed rollout. This is broken by the design of downloader and version_info.xml.
Posted 22 Mar, 2019 08:10:07 Top
Andrei Smolin


Add-in Express team


Posts: 16313
Joined: 2006-05-11
Hello Dirk,

I suppose you don't need to use ClickTwice: if you do not need automatic updates, reverting to previous versions, etc. you can use a .MSI.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 22 Mar, 2019 08:43:24 Top