Error during registering Outlook add-in

Add-in Express™ Support Service
That's what is more important than anything else

Error during registering Outlook add-in
 
uwekeim




Posts: 6
Joined: 2012-09-09
During registering an Outlook add-in in Visual Studio via right-click in "Solution Explorer" → "Add-in Express" → "Register", I get the following sequence of dialogs:

User added an image

Then after some time this appears:

User added an image

When clicking the blue "add-in-express-package-log.txt", my text editor opens and displays:

User added an image

I.e. the log file simply does not exist. I've also let Process Monitor run in the background while doing these steps and see no file activity for a file called "add-in-express-package-log.txt", too.

The Outlook add-in was first developed in 2012 and then sucessfully upgraded to the always latest Add-in Express version ever since.

On the other hand, registering a newly created Outlook add-in following your step-by-step manual works successfully.

My question:

How to further investigate (and finally solve) the erroneous registration process?
Posted 06 Oct, 2018 13:17:39 Top
Andrei Smolin


Add-in Express team


Posts: 16223
Joined: 2006-05-11
Hello,

Please look for add-in-express-package-log in c:\Windows\System32\.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 09 Oct, 2018 06:17:56 Top
uwekeim




Posts: 6
Joined: 2012-09-09
Non there, unfortunately.
Posted 09 Oct, 2018 07:28:21 Top
Andrei Smolin


Add-in Express team


Posts: 16223
Joined: 2006-05-11
Hello,

Could you please send us a project that reproduces this? Find our support email address in {Add-in Express installation folder}\readme.txt. Please make sure that youor email contains a link to this topic.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 10 Oct, 2018 05:04:21 Top
uwekeim




Posts: 6
Joined: 2012-09-09
You can reproduce the issue if you throw an exception within the c'tor of the ADXAddinModule-derived class.

[GuidAttribute("727366D9-6BAA-4BB1-A5FF-EAEA8E67FDD9"), ProgId("MyAddin1.AddinModule")]
public partial class AddinModule : AddinExpress.MSO.ADXAddinModule
{
	public AddinModule()
	{
		Application.EnableVisualStyles();
		InitializeComponent();
		

		throw new Exception("This exception will prevent registration, though you never will find out since no log will be written.");
	}


In my case an (indirect) exception was the cause, although I do not know until now, why the method I call from the c'tor actually throws.

Thus, an actual existing error log would really help.
Posted 11 Oct, 2018 12:04:24 Top
Andrei Smolin


Add-in Express team


Posts: 16223
Joined: 2006-05-11
Hello,

Thank you for the idea. It helped me to find the log on my machine: I've found it in "C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\Common7\IDE\.log". We will fix this bug in the next Add-in Expres build.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 12 Oct, 2018 07:12:06 Top