Older AddinExpress.MSO.2005 dll prevents update

Add-in Express™ Support Service
That's what is more important than anything else

Older AddinExpress.MSO.2005 dll prevents update
 
Ingrid Kellerer




Posts: 18
Joined: 2011-03-15
Hi,

I ran out of ideas ...

I maintain a pretty old VB.Net project (VS 2010!): Word-Addin with Addin-Express
Last update I sent to the customer was based on AddInExpress 8.7

Yesterday I updated to AddInExpress 9.1 and copied adxloader.dll to the projects loader-directory.
Afterwards I created a new msi setup.

But I am not able to update the previously installed Add-In.

Update installation finishes without errors.
But Add-in is not loaded in Word.

(Uninstalling previous version and then installing new version is fine.
But this is not what my customer expects :-( )


Furthermore I am not able to uninstall the new version (after update): Error 1001. Installationtypes of Assembly "xxx.dll" can not be requested --> At least one type in the assembly could not be loaded ...

I am able to uninstall if I copy the old 8.7 files (AddinExpress.MSO.2005.dll, AddinExpress.WD.2005.dll) to the installation directory (Programs (x86)).

CopyLocal of both AddinExpress.dll is set to false.

Tested on Win7 and Win10 system (both Office 2013)

Any ideas/help appreciated.

Regards
Ingrid


From adxregistrator.log:
[CODE]

Application Domain: C:\Program Files (x86)\nutzware\docUtilities\
Assembly Codebase: file:///C:/Windows/assembly/GAC_MSIL/AddinExpress.MSO.2005/9.1.4620.0__4416dd98f0861965/AddinExpress.MSO.2005.dll
Assembly Full Name: AddinExpress.MSO.2005, Version=9.1.4620.0, Culture=neutral, PublicKeyToken=4416dd98f0861965
Assembly Version: 9.1.4620.0

Exception Source:
Exception Type: System.IO.FileLoadException
Exception Message: The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

---- Stack Trace ----



(Outer Exception)
Date and Time: 06.07.2018 17:08:31
Machine Name: SEVENUP
IP Address: fe80::5880:457b:3203:d353%11
Current User: sevenup\ikeAdmin

Application Domain: C:\Program Files (x86)\nutzware\docUtilities\
Assembly Codebase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
Assembly Full Name: mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
Assembly Version: 4.0.0.0

Exception Source: mscorlib
Exception Type: System.IO.FileLoadException
Exception Message: Could not load file or assembly 'AddinExpress.WD.2005, Version=8.7.4430.2005, Culture=neutral, PublicKeyToken=e69a7e0f3592d2b8' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
Exception Target Site: GetExportedTypes
[\CODE]

From adxloader.log

[CODE}
17:21:42:807 1960 9952 Creating an instance of the managed class. Assembly identity: 'docUtilities, PublicKeyToken=85ED265F81A974D3'
17:21:42:837 1960 9952 Die Datei oder Assembly "AddinExpress.MSO.2005, Version=8.7.4430.0, Culture=neutral, PublicKeyToken=4416dd98f0861965" oder eine Abhängigkeit davon wurde nicht gefunden. Die gefundene Manifestdefinition der Assembly stimmt nicht mit dem Assemblyverweis überein. (Ausnahme von HRESULT: 0x80131040) Error code: 0x80131040
[\CODE}
Posted 06 Jul, 2018 10:57:16 Top
Ingrid Kellerer




Posts: 18
Joined: 2011-03-15
Any chance to get an answer?
Do you need more information?

Regards - Ingrid
Posted 10 Jul, 2018 02:08:01 Top
Andrei Smolin


Add-in Express team


Posts: 16201
Joined: 2006-05-11
Hello Ingrid,

I've sorry for the delay; yesterday we just needed some time to understand your issue. Today, I've had a fresh view and I see the problem as follows.

Your add-in loads AddinExpress.MSO.2005, Version=9.1.4620.0. The problem occurs when the add-in tries to load AddinExpress.WD.2005, Version=8.7.4430.2005. This means 1) your add-in project compiles with AddinExpress.WD.2005, Version=8.7.4430.2005 (not version 9.1) and 2) your setup project doesn't deploy AddinExpress.WD.2005, Version=8.7.4430.2005. Is this the case? If so, you need to modify your add-in project to use the AddinExpress.WD.2005.DLL installed on your machine.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 10 Jul, 2018 02:53:38 Top
Ingrid Kellerer




Posts: 18
Joined: 2011-03-15
Hi Andrei,

thanks for the answer.
Yes - that's what I assume.

But the project-file (vbproj) shows Version 9.1
Any other place where the wrong reference could be found?

<ItemGroup>
<Reference Include="AddinExpress.MSO.2005, Version=9.1.4620.0, Culture=neutral, PublicKeyToken=4416dd98f0861965, processorArchitecture=MSIL">
<SpecificVersion>False</SpecificVersion>
<HintPath>C:\Program Files (x86)\Add-in Express\Add-in Express for .NET\Bin\AddinExpress.MSO.2005.dll</HintPath>
</Reference>
<Reference Include="AddinExpress.WD.2005, Version=9.1.4620.0, Culture=neutral, PublicKeyToken=e69a7e0f3592d2b8, processorArchitecture=MSIL">
<SpecificVersion>False</SpecificVersion>
<HintPath>C:\Program Files (x86)\Add-in Express\Add-in Express for .NET\Bin\AddinExpress.WD.2005.dll</HintPath>
</Reference>



C:\Program Files (x86)\Add-in Express\Add-in Express for .NET\Bin\AddinExpress.MSO.2005.dll --> Version 9.1
Posted 10 Jul, 2018 03:12:14 Top
Ingrid Kellerer




Posts: 18
Joined: 2011-03-15
Now it's getting weird:
Within the setup-vbproj-file I found the version 8.9.4453 ....

But in the GUI it shows 9.1.4620

"{9F6F8455-1EF1-4B85-886A-4223BCC8E7F7}:_A2755A83C577A0F6092F11AC40EB13EF"
{
"AssemblyRegister" = "3:1"
"AssemblyIsInGAC" = "11:FALSE"
"AssemblyAsmDisplayName" = "8:AddinExpress.MSO.2005, Version=8.9.4453.0, Culture=neutral, PublicKeyToken=4416dd98f0861965, processorArchitecture=MSIL"
"ScatterAssemblies"
{
}
"SourcePath" = "8:AddinExpress.MSO.2005.dll"
"TargetName" = "8:"
"Tag" = "8:"
"Folder" = "8:_D3166896672F4C2CB92062B90A3F2E2D"
"Condition" = "8:"
"Transitive" = "11:FALSE"
"Vital" = "11:TRUE"
"ReadOnly" = "11:FALSE"
"Hidden" = "11:FALSE"
"System" = "11:FALSE"
"Permanent" = "11:FALSE"
"SharedLegacy" = "11:FALSE"
"PackageAs" = "3:1"
"Register" = "3:1"
"Exclude" = "11:FALSE"
"IsDependency" = "11:TRUE"
"IsolateTo" = "8:"
}
Posted 10 Jul, 2018 03:30:56 Top
Andrei Smolin


Add-in Express team


Posts: 16201
Joined: 2006-05-11
Hello Ingrid,

Ingrid Kellerer writes:
But in the GUI it shows 9.1.4620


Are you saying that in the Visual Studio Installer project that you have, you see AddinExpress.MSO.2005 version 9.1 in the Detected Dependency section and there's no that file in the list of files that your project deploys?

Note that by default, the list of files deployed by the setup project includes these items:
- Localized resources from {your add-in project}
- Primary output from {your add-in project}
- adxloader.dll.manifest
- adxloader.dll
- adxloader64.dll
- adxregistrator.exe.

Also by default, the Detected Dependencies section includes these items:
- Microsoft .NET Framework
- AddinExpress.MSO.2005.dll
- AddinExpress.MSO.2005.tlb (this one is marked as Excluded)
- an interop(s) for the Office host application(s) that your add-in supports e.g. Microsoft.Office.Interop.Outlook.dll
- Microsoft.Vbe.Interop.dll
- Office.dll
- stdole.dll

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 10 Jul, 2018 06:00:14 Top
Ingrid Kellerer




Posts: 18
Joined: 2011-03-15
Yes - all of the files are listed in the installer project.

As the problem "only" occurs when a previous version of my Add-In (build with the older Add-in-Express-Version) is installed:
Could it be that "something" doesn't get uninstalled or overwritten that still refers to the older versions.
But what ist this "something"??

Regards
Ingrid
Posted 10 Jul, 2018 06:26:47 Top
Andrei Smolin


Add-in Express team


Posts: 16201
Joined: 2006-05-11
Make sure your add-in project refers to AddinExpress.WD.2005, Version=9.1.XXXX and rebuild it. Also make sure your setup project deploys AddinExpress.WD.2005.dll version 9.1.XXXX. Finally, check the add-in's installation folder.

Maybe, there's an instance of an Office application running that loads a previous version of your add-in?

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 10 Jul, 2018 06:53:41 Top
Ingrid Kellerer




Posts: 18
Joined: 2011-03-15
Hi Andrei,

I checked everything once again - I searched all project files for AddinExpress.WD.2005 - in case there is a version number it's always 9.1.xxxx

I rebuilt the project - I rebuilt the setup

Same behaviour:
- If I install the new version of the add-in on a plain PC everything is ok - uninstall w/o issues.

- If I first install an older version of the add-in on the plain PC and afterwards the new version --> add-in doesn't load.
- uninstall: error 1001
- I first have to copy the old AddinExpress.dll-Versions (of MSO.2005.dll) plus adxloader.dll to the add-in installation folder then I am able to uninstall

During installation Word and all other office programs are closed.

What I recognized is

"Postbuildereignisse werden gestartet... (Postbuildevents have been started)
'Disable AllUsers Group' action failed. Can't read the ControlCondition view.
"

in the log of creating the setup.

I am not able to say if that message is new or not :-(

Any other ideas???

Regards
Ingrid
Posted 10 Jul, 2018 08:15:29 Top
Andrei Smolin


Add-in Express team


Posts: 16201
Joined: 2006-05-11
Please check the assemblies delivered to the add-in's installation folder. If these are okay, check if you have another version of your add-in deployed.

I'd like to access your machine remotely tomorrow but I will be available for a limited time in your morning: at 11:30 (or maybe a bit later) our time I'll become unavailable. I suggest using TeamViewer. In this case, you should send me your session ID and password to the support email address; please make sure your email contains a likn to this folder. Find the support email address in {Add-in Express installation folder}\readme.txt.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 10 Jul, 2018 09:56:54 Top