Installer hanged at Registering component

Add-in Express™ Support Service
That's what is more important than anything else

Installer hanged at Registering component
 
Rob Blackin




Posts: 68
Joined: 2016-02-20
Hi, the installer has been like this since the last 12 hours

User added an image

adxnet-v900-b4610-vs-pre

Please this is driving me nuts
Posted 07 Jun, 2018 10:47:31 Top
Rob Blackin




Posts: 68
Joined: 2016-02-20
Hey, now a new error and yes, I have envdte.dll on the installation folder

User added an image
Posted 07 Jun, 2018 10:50:32 Top
Rob Blackin




Posts: 68
Joined: 2016-02-20
I have visualstudio2017buildtools installed on this build machine
Posted 07 Jun, 2018 10:52:14 Top
Rob Blackin




Posts: 68
Joined: 2016-02-20
Now I get reactivations limit exceeded, nice
Posted 07 Jun, 2018 10:56:03 Top
Rob Blackin




Posts: 68
Joined: 2016-02-20
Since the installation failed so many times because the installer is extremely broken, now I cannot reinstall it, can you please give provide a solution.
Posted 07 Jun, 2018 10:57:16 Top
Andrei Smolin


Add-in Express team


Posts: 15919
Joined: 2006-05-11
Hello Rob,

I'm sorry for the inconvenience. We will fix this bug in the next Add-in Express build.

To All:

I write to let you know about the issue and workaround.

In the email correspondence following the messages above, it became clear that the installer found VS 2017 installed while what was installed actually was Visual Studio 2017 Build Tools. After that, some Visual Studio assemblies were not found and the installer failed. Rob installed VS 2017 Community and this let the installer complete.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 08 Jun, 2018 07:16:02 Top