OneNote add-ins

Add-in Express™ Support Service
That's what is more important than anything else

OneNote add-ins
Various issues 
Bargholz Thomas




Posts: 239
Joined: 2006-12-18
Hi,
I'm extending a current add-in to support OneNote, which leads to a couple of issues, that I hope you can give some advice about:

First of all: Debugging. I specify OneNote as the debugging app and run Visual Studio. OneNote starts, but clearly OneNote.exe is not doing the actual legwork - no breakpoints are triggered. I take it that it secretly starts another app or a service, and let that do the actual work, meaning my VS is debugging an app that does nothing. Do you know which process to attach the debugger to?

Second issue is with the ribbon. The add-in contains a ribbon tab with a few buttons.
On add-in load, it check the language settings so the UI uses the same language as the user, and it checks the version of OneNote, and then adjusts the icons accordingly (for the Office 2010 vs 2013+ look and feel, as the add-in supports 2010+ version of Office).
However, when the add-in is loaded in OneNote, there are no icons on any of the buttons (the text works fine). The text is changed, but icons just dissapeared. I have tried to bypass the icon setting code, but still there are no icons.
On all other Office app's this works just fine.
The code for updating text/icons is being called after the add-in is loaded. The logic is : In AddInStartupCompleted I send an event (AddIn.SendMessage) to inform that the add-in is now loaded. When receiving this event (AddIn.OnSendMessage) the code to update the icons and text is called.

Any other pointer on working with OneNote is much appreciated, as it appears to behave quite differently to the other Office apps.

Regards
Thomas
Posted 02 Feb, 2018 10:27:18 Top
Andrei Smolin


Add-in Express team


Posts: 14720
Joined: 2006-05-11
Hello Thomas,

You need to attach to a DllHost.exe having "Managed {.NET version}" in the Type column of the Attach to Process dialog.

As to disappearing icons, I've reproduced the issue: I get the message 'An error occurred while calling the callback: "getImage_Callback"'. This issue is filed down in our issue-tracking under #12210. When I have news about it, I'll send you a note.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 05 Feb, 2018 06:06:30 Top
Andrei Smolin


Add-in Express team


Posts: 14720
Joined: 2006-05-11
Hello Thomas,

We've published Add-in Express for Office and .NET 8.8.4450. Please see https://www.add-in-express.com/downloads/adxnet.php.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 22 Mar, 2018 08:31:06 Top