Outlook AddIn loaded but nothing shows up, how to troubleshoot?

Add-in Express™ Support Service
That's what is more important than anything else

Outlook AddIn loaded but nothing shows up, how to troubleshoot?
 
Subscribe
developer_cp




Posts: 47
Joined: 2016-10-28
1) My Addin is loaded and is not disabled
2) Is loaded by my Ribbon/Menu aren't showing up
3) Registry values are in the correct places (I have them in both for 32 and 64 bit just in case)
3) There isn't even a popup or exception being thrown...

Windows 7 64
Office Outlook 2010 32


How can I troubleshoot this? The same Addin works in Outlook 2016 32 without any problem.
Posted 12 Oct, 2017 15:32:24 Top
Alexander Bauer




Posts: 11
Joined: 2007-05-21
Maybe this helps:

Outlook add-in failing after Office update

Br,
Alex
Posted 13 Oct, 2017 01:46:34 Top
Dmitry Kostochko


Add-in Express team


Posts: 2731
Joined: 2004-04-05
Hello Eric,

Please check out the contents of the adxLoader.log file, probably it contains an exception or useful information. Also, please check the minOfficeVersionSupported attribute in your adxloader.dll.manifest file and let me know what minimum Outlook version is supported by your add-in.
Posted 13 Oct, 2017 05:01:05 Top
Dmitry Kostochko


Add-in Express team


Posts: 2731
Joined: 2004-04-05
Hi Alexander,

In that forum thread, I asked to provide more details regarding the issues you are faced with. Probably you have overlook my question, but please do provide more information about your project. If you have some demo projects that show the issues, please send them to our support email address.
Posted 13 Oct, 2017 05:07:39 Top
Alexander Bauer




Posts: 11
Joined: 2007-05-21
Hi Dmitry,

my problem was solved in that thread.
With the registry key published by MS, the add-in works as before.

Br,
Alex
Posted 13 Oct, 2017 05:23:28 Top
Dmitry Kostochko


Add-in Express team


Posts: 2731
Joined: 2004-04-05
Hi Alexander,

Thank you!
Posted 13 Oct, 2017 05:27:20 Top
developer_cp




Posts: 47
Joined: 2016-10-28
check the minOfficeVersionSupported attribute in your adxloader.dll.manifest file


That was it! Wouldn't it be nice if it prints some messages?! :P
Or at least during compile time: "This plugin only support minOfficeVersionSupported: 14.0" etc.

The most misleading part is that, Outlook showed the plugin was LOADED successfully.
Posted 16 Oct, 2017 09:43:17 Top
Dmitry Kostochko


Add-in Express team


Posts: 2731
Joined: 2004-04-05
Hello Eric,

Thank you for the good news!

Wouldn't it be nice if it prints some messages?!


Such messages exist in the adxloader.log file contents.

The most misleading part is that, Outlook showed the plugin was LOADED successfully.


Sorry, we cannot unload an add-in in this situation because:
- Office applications do not support something like e.Cancel = true during the add-in loading.
- Several versions of a particular Office application can be installed on the same machine but all of them use the same registry key to determine whether to load an add-in or not.
Posted 16 Oct, 2017 10:44:09 Top
developer_cp




Posts: 47
Joined: 2016-10-28
Is there an example or simple function in ADX library that could verify the running version against the minOfficeVersionSupported?

Perhaps, AddinModule.Supported()?

Then developer could simply do during the AddinCompleted hook

if (!AddinModule.Supported())
MessageBox.Show("Your version of Outlook is not supported, please upgrade blahblah...");


I mean this wouldn't be a difficult feature/function to implement. Probably less than a few lines of code.

Just a suggestion.

Thanks!
Posted 16 Oct, 2017 10:57:29 Top
Dmitry Kostochko


Add-in Express team


Posts: 2731
Joined: 2004-04-05
Hello Eric,

Thank you for your suggestion! I am afraid we will not be able to implement it because an AddinModule instance is not created when your add-in is being loaded by an outdated! version of a host application.

BTW, I think you can implement something like this on your side, for example at the installation time via custom actions...
Posted 16 Oct, 2017 11:05:07 Top