Change Excel minimum supported version

Add-in Express™ Support Service
That's what is more important than anything else

Only registered users are allowed to subscribe.
Change Excel minimum supported version
 
Subscribe
Albert Siagian




Posts: 83
Joined: 2012-05-25
Hello,

Using v8.6, how can I change minimum supported Excel version ? I think in the past, I can just replace Interop assembly from add-in express redistributable folder. I have done it, but still get following error:

Loader version: 8.6.4408.0
09:52:11:467 0812 2100 The minimum supported Office version is 15
09:52:11:467 0812 2100 The host's version is 14.0.7183.0

I originally selected Excel 2013, but now I want it minimum Excel 2010. My project interops have correctly shown 14, but looks like it still doesn't recognize the add-in in XL 2010.

Regards
Albert
Posted 27 Sep, 2017 22:27:07 Top
Albert Siagian




Posts: 83
Joined: 2012-05-25
Additional info:

I have replaced 3 files from this folder and restart Visual Studio :
C:\Program Files (x86)\Add-in Express\Add-in Express for .NET\Redistributables\Interop Assemblies\Office 2010

Microsoft.Office.Interop.Excel.dll
Microsoft.Vbe.Interop.dll
Office.dll

But still can't see it in Excel 2010
Posted 27 Sep, 2017 22:41:30 Top
Andrei Smolin


Add-in Express team


Posts: 14094
Joined: 2006-05-11
Hello Albert,

09:52:11:467 0812 2100 The minimum supported Office version is 15


this is specified in the manifest; see adxloader.dll.manifest in the Loader folder in your add-in project.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 28 Sep, 2017 04:07:17 Top
Albert Siagian




Posts: 83
Joined: 2012-05-25
Thanks Andrei, it's working now.

Regards
Albert
Posted 28 Sep, 2017 05:16:44 Top
Andrei Smolin


Add-in Express team


Posts: 14094
Joined: 2006-05-11
You are welcome!

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 28 Sep, 2017 05:22:13 Top