Installation problem on Terminal Servers

Add-in Express™ Support Service
That's what is more important than anything else

Installation problem on Terminal Servers
 
Subscribe
Sebastian Horstmann




Posts: 11
Joined: 2017-07-26
Hello from Germany,

we use an Outlook-Add-In created Add-in Express. On local clients there is no problem with it, but when installing the addin on a Terminal Server the Add-In works in Outlook until the next login of the user. Then the addin is installed in %appshare% but not registered in Outlook anymore - we have to reinstall ist.

We followed your instructions from your documentation (how to create msi for terminal servers).

Do you have any idea, why we encounter this problem?
Posted 05 Sep, 2017 05:15:09 Top
Andrei Smolin


Add-in Express team


Posts: 14140
Joined: 2006-05-11
Hello Sebastian,

I don't know the answer off the top of my head,. I need more info to suggest anything.

Please reinstall your add-in, start Outlook and send me copies of these files:

- ADX.NET 8.6 and below: 1) {My Documents}\Add-in Express\adxregistrator.log in the profile of the user who runs the installer, 2) {My Documents}\Add-in Express\adxloader.log in the profile of the user who starts Outlook
- ADX.NET 8.7 and higher: 1) {user profile}\AppData\Local\Temp\<ProductName>\adxregistrator.log in the profile of the user who runs the installer, 2) {user profile}\AppData\Local\Temp\<ProductName>\adxloader.log in the profile of the user who starts Outlook

Then let the user log in for the second time and start Outlook and send me another copy of adxloader.log. Do I understand you correct: you talk about the same user logging in for the second time?

You can find the support email address in {Add-in Express installation folder}\readme.txt. Please make sure your email contains a link to this topic.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 05 Sep, 2017 05:51:30 Top
Sebastian Horstmann




Posts: 11
Joined: 2017-07-26
Hello Andrei,

yes, we talk about the same user logging in for the second time.

When i install the AddIn the Log-Files are not stored in "{My Documents}\Add-in-Express\". I do not find them anywhere on the system. So maybe this is the problem?

Our local clients do have the log files written, but not our Terminal-Servers; so i think its a problem with permissions. We have to check these.
Posted 05 Sep, 2017 07:29:13 Top
Andrei Smolin


Add-in Express team


Posts: 14140
Joined: 2006-05-11
Hello Sebastian,

Feel free to send me these files whenever you need.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 05 Sep, 2017 07:35:19 Top
Sebastian Horstmann




Posts: 11
Joined: 2017-07-26
Hello,

so i have new information about the server configuration:

we use "server stored user profiles" and "user profile disks". If i grant myself adminstrative permissions on one of our terminal servers, i am also not able to generate the logfiles. The files aren't be created by the installer of the addin.

The same installer works fine on local clients.
Posted 05 Sep, 2017 08:06:26 Top
Andrei Smolin


Add-in Express team


Posts: 14140
Joined: 2006-05-11
Hello Sebastian,

I assume the add-in is per machine; is this correct? What is %appshare%?

Do you pass the /LogFileLocation parameter to adxregistrator.exe? If yes, what path do you use?

Do you specify the LogFileLocation element in adxloader.dll.manifest? If yes, what path do you use?

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 05 Sep, 2017 09:10:23 Top
Sebastian Horstmann




Posts: 11
Joined: 2017-07-26
Hello

and sorry, that was my fault. I meant %appdata% not %appshare%.

I do not pass the /LogFileLocation parameter to adxregistrator. I haven't changed anything in adxloader.dll.manifest - everything is set default.

The add-in is not per machine it is installed per user.
Posted 12 Sep, 2017 03:25:02 Top
Andrei Smolin


Add-in Express team


Posts: 14140
Joined: 2006-05-11
Hello Sebastian,

Thank you. I suppose you use adxregistrator.exe v. 8.7 (not 8.6 or earlier), you install to %appdatalocal% (not to %appdata%), and an admin applied a restriction(s) on writing to %appdatalocal% and/or to HKCU.

If this isn't the case, install the add-in using MSIEXEC.EXE. This allows specifying parameters one of which allows creating a verbose log. Please send me such a log file.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 13 Sep, 2017 07:06:27 Top
Sebastian Horstmann




Posts: 11
Joined: 2017-07-26
Hi Andrei Smolin,

sorry for the late response.

I uploaded the logfile to: https://cloud.deos-ag.com/cloud/index.php/s/5Xd6R46mmGa9Wvv (File avaiable until 31.12.2017)

The logfile contains some errors, but i am not sure which error marks the problem.

After the installation, i can run outlook and the add in is loaded and can be used until i log off from the terminal server.
Posted 25 Sep, 2017 03:16:48 Top
Andrei Smolin


Add-in Express team


Posts: 14140
Joined: 2006-05-11
Hello Sebastian,

This is the error that the log file contains:

DEBUG: Error 2911: Could not remove the folder C:\Config.Msi\.
MSI (s) (F4:6C) [09:43:10:338]: Note: 1: 2318 2:
Bei der Installation dieses Pakets ist ein unerwarteter Fehler aufgetreten. Es liegt eventuell ein das Paket betreffendes Problem vor. Der Fehlercode ist 2911. Argumente: C:\Config.Msi\, ,


We suppose the terminal server's settings don't allow the installer/user preserve the registry between session. I suggest that you talk to an admin.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 25 Sep, 2017 08:20:44 Top