Excel Add-in Doesn't load, but runs if I manually enable it.

Add-in Express™ Support Service
That's what is more important than anything else

Excel Add-in Doesn't load, but runs if I manually enable it.
 
Michael Benowitz




Posts: 7
Joined: 2017-02-03
Hello,

I installed an excel add-in on a Terminal Server running Server 2012 and excel 2010. I installed it as administrator and I'm logged into the server as administrator.

When I launch excel the com add-in isn't loaded. I f I manually enable it, the add-in runs correctly. But I have to manually enable it every time I launch Excel. Any suggestions for trouble shooting the issue. I included the adxregirator log below

Thanks

Mike

Add-in Express Registrator Log File: 05/26/2017 08:33:00

Installation directory: C:\Program Files (x86)\FUND E-Z Development Corporation\FUNDEZ11.XL\
Registrator version: 8.6.4408.0
Operating System: Microsoft Windows Server 2012 R2 Standard Edition (build 9600), 64-bit
Process Owner: Administrator
Command Line: "C:\Program Files (x86)\FUND E-Z Development Corporation\FUNDEZ11.XL\adxregistrator.exe" /install="FUNDEZ11.XL.dll" /privileges=admin
Run 'As Administrator': Yes
Process Elevated: Yes
Integrity Level: High
UAC (User Account Control): On
--------------------------------------------------------------
08:33:00 0292 Starting the add-in registration process.
08:33:00 0292 Loading mscoree.dll
08:33:00 0292 Success.
08:33:00 0292 .NET Framework installation directory:
08:33:00 0292 The latest version of .NET Framework: 'v4.0.30319'
08:33:00 0292 Loading CLR: v4.0.30319.
08:33:00 0292 Calling CLRCreateInstance method.
08:33:00 0292 Success.
08:33:00 0292 Calling GetRuntime method.
08:33:00 0292 Success.
08:33:00 0292 Checking if the hosting API of .NET Framework v4.0 beta is installed.
08:33:00 0292 The hosting API is up to date.
08:33:00 0292 Calling GetInterface method for the CorRuntimeHost interface.
08:33:00 0292 Success.
08:33:00 0292 Starting CLR...
08:33:00 0292 Success.
08:33:00 0292 Getting the CLR version.
08:33:00 0292 The CLR v4.0.30319 has been initialized successfully.
08:33:00 0292 Creating a new domain setup.
08:33:00 0292 Success.
08:33:00 0292 Getting the add-in directory.
08:33:00 0292 Success. The directory is 'C:\Program Files (x86)\FUND E-Z Development Corporation\FUNDEZ11.XL\'
08:33:00 0292 The 'shadow copy' is disabled.
08:33:00 0292 Creating a new application domain.
08:33:00 0292 Success.
08:33:00 0292 Getting the base directory for the domain.
08:33:00 0292 Success. The directory is 'C:\Program Files (x86)\FUND E-Z Development Corporation\FUNDEZ11.XL\'.
08:33:00 0292 Searching for the Add-in Express core library.
08:33:00 0292 Success. The 'AddinExpress.MSO.2005.dll' file is found.
08:33:00 0292 Creating an instance of the 'AddinExpress.Deployment.ADXRegistrator' class.
08:33:00 0292 Assembly identity is 'AddinExpress.MSO.2005'.
08:33:00 0292 Success.
08:33:00 0292 Unwrapping the instance of the 'AddinExpress.Deployment.ADXRegistrator' class.
08:33:00 0292 Success.
08:33:00 0292 Calling the managed registration procedure (DISPID = 1610743823).
08:33:09 0292 Registration success.
08:33:09 0292 The add-in registration process is completed with HRESULT = 0.
Posted 26 May, 2017 07:56:37 Top
Andrei Smolin


Add-in Express team


Posts: 14094
Joined: 2006-05-11
Hello Michael,

Thank you for providing the adxregistrator.log. Please check if adxloader.log gets updated when you start Excel and find your add-in not loaded. If the file gets updated, lease post it here. If it isn't updated, check section Troubleshooting add-in loading at https://www.add-in-express.com/docs/troubleshooting-tips.php#troubleshooting_add-in_loading.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 26 May, 2017 08:37:48 Top