Add-in doesn't load

Add-in Express™ Support Service
That's what is more important than anything else

Add-in doesn't load
 
Matteo Pasqualin




Posts: 27
Joined: 2006-08-04
Hi Sergey,

with Visual Studio 2005 I can't no more load my add-in in Outlook. It always worked, till now. MyFirstOutlookAddIn project sample instead, loads and works correctly. I removed and reinstalled Add-In Express because of dll error before this issue...

Can you help me?

Thank you

Matteo
Posted 02 Oct, 2006 04:15:51 Top
Sergey Grischenko


Add-in Express team


Posts: 7229
Joined: 2004-07-05
Hi Matteo.

Do you see the add-in in the 'COM Add-ins' dialog in Outlook?
Do you have any other add-ins written for .NET 1.1 and running at the same time in Outlook?
Posted 02 Oct, 2006 08:35:56 Top
Matteo Pasqualin




Posts: 27
Joined: 2006-08-04
Hi Sergey,

well, sorry I did'nt understand your first question, in Outlook where?
I have'nt others add-ins written in .NET 1.1.

Anyway, I created another project and add-in loads correctly.

In my previous project, the problem concerned the Loader, when I opened Outlook I got an error. Moreover, when I registered the adx project an error said that an assembly (AddinExpress.MSO.2005) ought to be registered as Interop COM with RegAsm /tlb. Well... I registered it, without success. Sorry for the lack of details, but the problem was hard to me to understand.

Thanx

Matteo

Posted 02 Oct, 2006 09:05:00 Top
Sergey Grischenko


Add-in Express team


Posts: 7229
Joined: 2004-07-05
The 'COM Add-ins' dialog is located in 'Tools->Options->Other->Advanced Options->COM Add-ins'.

Have you ever tested the setup project on the development PC?
Do you have the AddinExpress.MSO.2005.tlb file in the Detected Dependencies of the setup project? If so, this file should necessarily be excluded.

Well... I registered it, without success

Please try to reinstall ADX.
Posted 02 Oct, 2006 09:57:08 Top
Matteo Pasqualin




Posts: 27
Joined: 2006-08-04
Hi Sergey,

I reinstalled Add-In, I also discovered that if you have problem with dll as I wrote you before, it is necessary to restart the system too, to really solve the problem. I then created another project and finally works.

The toolbar I builded works fine without the setting you mentioned about COM Add-ins in outlook. In my Outlook 2003 version I haven't set COM Add-ins.

Now, I have a suggestion for the Add-In Express team, if you don't mind.
Why don't you open a contest, I mean the best product build with one of the add-in delivered by Add-In Express? The winner could win something you will decide, or the winner could win the free use of all Add-In products or some of them? What do you think? Does it sound a good idea?

Thanx for support, regards.

Matteo
Posted 03 Oct, 2006 04:26:07 Top
Sergey Grischenko


Add-in Express team


Posts: 7229
Joined: 2004-07-05
Hi Matteo.

Thank you for the suggestion. We will think it over.
Posted 03 Oct, 2006 09:18:23 Top