Published and installed Add-in does not show up in Outlook on client computers

Add-in Express™ Support Service
That's what is more important than anything else

Published and installed Add-in does not show up in Outlook on client computers
 
Lance Friedemann




Posts: 24
Joined: 2017-02-10
Addin does not populate on client computers after installation.

- Installed the setup.exe on the client computer as Administrator.
- Checked registry and it shows '3' for load behavior
- Checked Addins on the client computer Outlook under File > Options > Add-ins and it shows my ADX Addin as Active.
- Double clicking the application on the client computer shows that it is registered.
- Ran setup as administrator
- Changed Compile in project to Any CPU.

Log file shows error:

An attempt was made to load a program with an incorrect format.

- Check the client computer and the Outlook bitness is x64.



What else should I do?
Posted 27 Feb, 2017 12:30:09 Top
Lance Friedemann




Posts: 24
Joined: 2017-02-10
Okay I got it work. I put the software into Release mode under Compile Configuration. Also, apparently the publisher does not automatically build the application like a regular WinForm application in Visual Studio. You must manually build the application and then run the publisher. Also, having to manually copy files from the C:\ of the development computer to a published location and manually update the version number is a pain. These 3 items should be fixed as this is not normal behavior for Visual Studio.
Posted 27 Feb, 2017 13:57:00 Top
Andrei Smolin


Add-in Express team


Posts: 14108
Joined: 2006-05-11
Hello Lance,

Thank you for the suggestion.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 28 Feb, 2017 06:54:44 Top