Problem: Registering ADX project during development

Add-in Express™ Support Service
That's what is more important than anything else

Problem: Registering ADX project during development
 
Thomas Guenther




Posts: 94
Joined: 2006-02-20
Hi!

I'm using Add-In-Express .Net Version 2.7 with MS Visual Studio 2003 and Win XP SP2 + Laast fixes.

I have a problem with registering ADX project during development.
Whenever i try to register my project i get the following error message:

"Registering of a COM-Interop failed. Could not find a type library for assembly 'AddinExpress.MSO'." (translated from german language)

But after all i get a MessageBox saying "The ADX project registration succeeded."

While testing my Outlook-AddIn it stops working.

If i create a Setup-Project all works fine. But it takes so much time for each little changes reinstall the addin and configure all neccessary options.

Reinstalling AddIn-Express including registry cleanup did not solve the problem. Maybe there's something wrong with the GAC ?

Any ideas ?

Thank you for your help!

Ciao,
Thomas Guenther
Posted 13 Sep, 2006 10:24:11 Top
Sergey Grischenko


Add-in Express team


Posts: 7224
Joined: 2004-07-05
Hi Thomas.

Does the add-in project refers to the AddinExpress.MSO.dll assembly located in the ADX installation folder in a local directory?
Also please check the 'Copy Local' property of the AddinExpress.MSO assembly in the References of the add-in project. It should be set to False.
Posted 13 Sep, 2006 15:15:24 Top
Thomas Guenther




Posts: 94
Joined: 2006-02-20
Hi Sergey!

Yes, the add-in project refers to the AddinExpress.MSO.dll assembly located in the ADX installation folder in a local directory and the 'Copy Local' property is set to False. I tested this behaviour wit some of the provided examples of Add-In-Express and all worked fine. So there must be something wrong with my project setup. I removed AddinExpress.MSO.dll from my dependencies and added it afterwards without success in solving the problem.

Ciao,
Thomas
Posted 14 Sep, 2006 02:21:42 Top
Sergey Grischenko


Add-in Express team


Posts: 7224
Joined: 2004-07-05
Hi Thomas.

Does the issue still exist?
Posted 20 Sep, 2006 05:49:16 Top
Thomas Guenther




Posts: 94
Joined: 2006-02-20
Hi Sergey!

Sorry for my late answer. I was very busy these days...

Yes the issue still exists. I created a new project today and copied all my files into it but i get still the same error while registering the ADX project for debugging.

Now i get a further error message saying "An invocation target has thrown an exception" (translated from german) with an AddinExpress.Wizard title in message window.

Unfortunatly it's impossible for me to see if i misconfigured one or more necessary libraries or if there's a problem with registering AddinExpress.MSO itself.

Best regards,
Thomas
Posted 28 Sep, 2006 08:14:02 Top
Sergey Grischenko


Add-in Express team


Posts: 7224
Joined: 2004-07-05
Hi Thomas.

Do you have any code in the constructor of the addimodule?
Posted 28 Sep, 2006 12:29:59 Top
Thomas Guenther




Posts: 94
Joined: 2006-02-20
Hi Sergey,

Yes i'm doing some initializations in the default constructor...

I commented them out and did a recompile. Afterwards i tried to register the addin again but without success.
Posted 29 Sep, 2006 02:26:12 Top
Sergey Grischenko


Add-in Express team


Posts: 7224
Joined: 2004-07-05
Hi Thomas.

Please try the following:
1. Create a new project with the same name but in another location.
2. Move the current code to the new project.
3. Register the project.
Posted 29 Sep, 2006 16:09:04 Top