Add-In Expess UI

Add-in Express™ Support Service
That's what is more important than anything else

Add-In Expess UI
 
David Waugh




Posts: 1
Joined: 2016-05-04
Hi Add-In Express,

I'm debugging a UI issue with our long-lived Add-In Express application. We are fully updated to 8.1.



On a physical Win10 machine with Excel 2016, my Add-In forms look correct (spacing and UI details). The UI renders correctly at all available resolutions.

Local Win10 machine:
http://postimg.org/image/f5c550nxd/



However, when I run the same application in a Win10 Virtual Machine, the UI looks very strange, like:

Win10 machine running on VM:
http://postimg.org/image/8tzzyg84h/


Notice the blue border (from Win10's look and feel) is incomplete, and the header title is shifted down unexpectedly over the textbox. I've grayed out a few things for anonymity.


Is this something you have encountered? Can you tell me anything about this issue? Like, can you confirm that this is a VM-exclusive issue, or is this suggesting there is a configuration where the same UI issues could occur on a physical customer machine?

Thank you!
Posted 10 May, 2016 20:38:49 Top
Dmitry Kostochko


Add-in Express team


Posts: 2839
Joined: 2004-04-05
Hi David,

As far as I can see you use the native System.Windows.Forms.Form form, correct? If so, you can create a new Windows Forms Application project, add that form to the newly created project and test the project on your virtual machine.

Please let me know about the results in any case.
Posted 11 May, 2016 06:05:00 Top