Com loading error with simple Outlook addin

Add-in Express™ Support Service
That's what is more important than anything else

Com loading error with simple Outlook addin
 
Sergey Grischenko


Add-in Express team


Posts: 7225
Joined: 2004-07-05
Hi Ralph.

Does the issue with registering the add-in via the 'Register ADX Project' option still exist?
Posted 07 Aug, 2006 18:53:52 Top
Ralph Smith




Posts: 45
Joined: 2006-06-19
Hello Sergey,

Unfortunately 'Register ADX Project' option still doesn't work. If I register only after a build, I get the COM error.

I have to run the addin's setup msi after every build, to test. It's slowing us down as you can imagine :) But it's a lot better than where we were for the last few days ( with nothing working at all ).

Any help working around this issue would be greatly appreciated.

Best regards
Posted 07 Aug, 2006 20:02:29 Top
Ralph Smith




Posts: 45
Joined: 2006-06-19
Hello,

'Register COM Interop' set to true on the project causes the addin to fail during Loading as well.

One component we rely on requires this. Is there a way to turn this option on without having th addin fail during loading?

Best regards
Posted 07 Aug, 2006 23:02:23 Top
Matt Driver


Matt


Posts: 152
Joined: 2004-08-17
Do you have other assemblied, ActiveX and dll's that the project relies on ? I have a complete add-in with the above in it and when I build and simply register the add-in it fails like above. I do have the uninstall before I build and re-install after each build its slow but its the only way I have got it to work as well I just assumed this was normal.

Matt
Posted 08 Aug, 2006 07:39:51 Top
Sergey Grischenko


Add-in Express team


Posts: 7225
Joined: 2004-07-05
Hi Ralph.

You shouldn't uncheck the 'Register for COM Interop' property because all COM Add-ins require the registration for COM interop.
Can you send me the add-in project? I will check it.
Posted 09 Aug, 2006 06:54:30 Top